1Password X Beta w/ 1Password Beta for Mac and Chrome on Catalina do not play well together

Starting from scratch (new computer):
- Mac OSX Catalina 10.15.3
- 1Password 7 Version 7.4.2.BETA-3 (70402003)
- Google Chrome 79.0.3945.130
- 1Password X Beta 1.18.6

I login to 1Password (Desktop) - all works great
I use the menu-bar icon to interact with 1Password Desktop - all works great
I install Chrome and 1P X Beta, it asks to login to my two accounts (Personal and Work) - seems to behave.

However, now when I click the 1P icon in EITHER Chrome or on the Mac Menu bar, I get no window.
I also cannot use the hot key (Cmd-/).
Nor can I use the desktop app to open and fill a web page (the page never even opens)

Yes, Chrome is my default browser. Yes, I've tried quitting all the relevant apps and reopening. Yes, I've tried rebooting.

At this point I'm back to using the 1Password Desktop Extension for Chrome and I've disabled 1Password X Beta.

1Password Version: 1Password 7 Version 7.4.2.BETA-3 (70402003)
Extension Version: 1Password X Beta 1.18.6
OS Version: OSX 10.15.3
Sync Type: 1Password


  • esquaredesquared
    Community Member

    Updated to 1Password 7 Version 7.4.3-BETA-0 and still no joy.

  • ag_tommyag_tommy

    Team Member


    Could you check to see if you have both 1Password X and the traditional 1Password extension installed and enabled at the same time? Please try disabling the traditional extension if you do.

  • esquaredesquared
    Community Member

    I have both installed at the moment, but only have ever had one enabled at a given time. I've even gone so far as to quit chrome in between. With 1PXBeta enabled, I now get a "Install the 1Password extension" dialog when using the shortcut Cmd-/ or the Mac menu bar icon. 1PXBeta does ask to unlock 1P and accepts a fingerprint (I've got that turned on), so clearly the connection between the agent in Chrome and the desktop app is working at some level. However, once I've unlocked 1P Desktop, the chrome icon still shows me a "enter your password" box.

  • kaitlynkaitlyn

    Team Member

    Hey there @esquared! I'm sorry to hear you're having trouble with Desktop App Integration, and I'm happy to help.

    At first thought, it seems like 1Password for Mac and 1Password X aren't integrating properly. To double check, please open the 1Password X settings page by right clicking on the 1Password icon in your browser toolbar and selecting Settings in the context menu. Do you see an error message towards the top of that page?

    If you wouldn't mind, could you grab your 1Password X logs as well and let me know if there are any errors there? To do so, you can follow this guide. I look forward to hearing what you find.

  • esquaredesquared
    Community Member

    @kaitlyn - yes, the settings for 1PXBeta say "unable to establish connection with a 1Password desktop app."

    I have generated a log, but the log includes account/user UUIDs and Keys that look all the world like SHA or other hashes and I wonder about the security of posting those to a world-readable forum. Is there another means to get you that information.

  • kaitlynkaitlyn

    Team Member

    @esquared – Absolutely. Could you send the log via email to [email protected] with a link to this forum post? Feel free to remove any UUIDs you don't feel comfortable including. I won't be looking at that – the errors are the most important piece of info for me.

This discussion has been closed.