eTrade password autofilling an incorrect password

Trade 1password mini does not autofill correct password into eTrade. It is autofilling the correct user name and something asterisked out into the password field that returns incorrect password message. I can successfully copy and paste the password in from 1Password, so I know the correct password is being stored. Same problem with two separate eTrade logins.

1Password Version: 7.3.1
Extension Version: 7.3.1
OS Version: 10.14.1
Sync Type: 1Password Subscription


  • ag_anaag_ana

    Team Member

    Hi @AirKevin!

    Can you please share the full URL where this is happening please, so we can test the website and see if we can reproduce the issue?

    Thank you!

  • AirKevinAirKevin
    edited August 2019

    Yes, sorry for the late reply, it is still an issue:

    Allowing 1PW to autofill the password insert an incorrect password. Copying the password by hand from 1PW works.

    Only an issue for the eTrade site.

  • Hi @AirKevin,

    Can you try saving a new Login item for me please using the steps detailed on our support page How to save a Login manually in your browser and see if a new Login item behaves any differently. I have tested saving and filling and as best I can see the field is being correctly filled by 1Password. What I'm sadly unable to test is actually submitting with valid credentials - the requirements for creating an account mean I can't test as much as I'd have like to. Let's see if a new item behaves any differently from your existing one.

  • This is happening to me as well, in both Chrome and Firefox on a Mac, before and after clearing caches. If I use autofill from the browser plugins or from the desktop app, I get an error stating "We're sorry - we were unable to process your request. Please try logging on again". (see attached screencap)

    If I copy/paste both the username and the password from my 1Password Desktop app, it works fine.


  • Hey Steve (@parkerpress)! What's the exact URL you're trying to sign in on? And which browser extension (the desktop app-dependent one or 1Password X) are you using? I'll see if any of my colleagues have an ETRADE account and can test this out on our end. If we can reproduce I'll file a bug report to hopefully get this resolved soon. :smile:

  • As I mentioned in the original message mentioned above, its both the desktop app and the plugins in Chrome and Firefox.

    It happens on any ettrade URL, from "" to saved links (when a saved link opens, then asks for a password).

    However you get to the pages, at the point where it asks for a username and password, using Autofill always fails, when manually opening the desktop app, and copy/pasting both the username and password on that same page works fine.

  • Hey @parkerpress, I only asked because on the main E-Trade page, I don't see any login form. If I click the Log on button at the top I'm taken to — I just wanted to make sure this was where you ended up, too.

    I had one of my colleagues try to reproduce this, and they had no issue in filling and logging in successfully. They tested both the standard extension as well as 1Password X.

    Can you check for me what's in your web form details for this item? I'm wondering if the details saved there maybe do not match what you see in the normal item details that are visible at the top of your item.

  • OK. Here's exactly what I tried tonight on Mac OS X 10.14.6, Firefox 69.0.1 (64-bit), 1Password-X Plugin 1.16.2, 1Password Desktop App 7.3.2 (70302004).

    • Clear Cache in Firefox.
    • Launch Firefox.
    • Open, URL automatically changes to
    • Click the "Login" button. URL changes to
    • Click on the 1password icon in the username field,
    • Enter CMD-. to enter my 1PW password
    • Click "Autofill" on my eTrade entry. Username and password field fills in
    • Click the Login button
    • I get the failed message shown in my message
    • Launch the 1Password Desktop Application
    • Find my eTrade entry
    • Click the "copy" button next to the user name, then paste it in the username field on the failed login panel
    • Back on 1Password, click the "copy" button next to the password, then paste it into the password field on the failed login panel
    • Click the Login button, and magically I'm logged in to my account.

    This is before and after restarts. Before and after clearing Cache in my browser. And in Private Firefox windows as well.

    I thought maybe it's because I had the "1Password-X Plugin" and the "1Password extension (desktop app required)" at the same time, installed so I disabled that plugin and reran the same tests with the same results

    I tried the same exact experiment on Chrome Version 77.0.3865.90 (Official Build) (64-bit) with "1Password X - Password Manager v 1.16.2" and I'm having the same results in Chrome as well.

    I don't know if you have an extension for Safari, but heading that way next.

  • ag_yaronag_yaron

    Team Member

    Hey guys,
    I have also tested this website and it seems to autofill correctly for me. Although I do not have an account, I just wanted to make sure it autofills the username and password fields correctly.

    @parkerpress , can you please try the following:
    1. Open your 1Password app, locate the login for this website and delete it from 1Password (copy the username/password to a temporary location first).
    2. Go to
    3. Manually fill in your username and password and log in. 1Password will pop up asking you if you'd like to save it as a new login - confirm and save it.
    4. Log back out and try to autofill using the new login you just saved in 1Password, see if it works.

    I hope that will do the trick.

  • @Yaron : That did it. Deleting the entry I had (and all the little "Key" entries that 1Password keeps making), then clearing cache, and restarting the browser now lets me use the 1Password entry.

    Thanks for the idea. I don't think I would have ever thought deleting the entry to recreate it. I know I lost the password history this way, but can live without that to have it working again...

  • ag_yaronag_yaron

    Team Member

    I'm glad to hear that worked. I don't think deleting cache or restarting the browser was necessary, but all in all I'm just happy you have a working login :)

    The deleted login will remain in the 1Password app's trash for one year, you can recover it if you need it, and just keep using the new login you created.

  • onodera3onodera3
    edited March 7

    @parkerpress thank you so much for those steps!

    I've been having this problem for over a year and I never considered that it could have been 1Password itself. I surely thought it was ETrade that had a problem. I had a few calls with them that didn't go anywhere (honestly I even considered closing my account with them). Cleared caches, tried different browsers, changing my password, etc... It didn't help that the error message sounds like they are having technical difficulties. I could still login using my mobile device, but this was really frustrating. Doing a random search on google and I ended up here and was able to finally solve this!

    I'm guessing there is some form field value that 1Password saved that became incompatible with a change on the ETrade site. I deleted all form fields besides the username and password and it now works. :) Something to keep in mind in general for old login entries. This one was quite old, created many years ago.

  • ag_yaronag_yaron

    Team Member

    Thanks for the info @onodera3 .
    Indeed, at some point in time websites will change their design/webpages and that might affect the stored login in 1Password, so if you ever encounter issues when autofilling, step one is to try and create a new login for that website (although you can also get technical and remove fields from the saved login you already have).

    Glad you managed :)

  • I have encountered this same problem and have some new information. It appears that 1Password adds some additional information to the form when auto-filling that confuses the E-Trade login system. This occurs for me with current 1Password on both Chrome and Safari on Mac.

    If I manually copy the password from 1Password app to either Chrome or Safari, I am able to log in successfully, so it's not that 1P is remembering a stale password.

  • ag_anaag_ana

    Team Member


    It appears that 1Password adds some additional information to the form when auto-filling that confuses the E-Trade login system.

    Can you please clarify what additional information this is? Thank you!

  • ag_yaronag_yaron

    Team Member

    I think what @blendedfruit is seeing is rather old data that 1Password captured before etrade changed their login form.

    Please follow the suggestions above in this discussion and create a new login for etrade so that 1Password will capture the current and relevant fields, instead of the outdated ones you have in your current login fro etrade. You can use this method:

    Let us know how it goes.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file