Not auto filling some websites in Safari

1 Password has stopped filling some Sign-ins in Safari. The 1PW Extension list the correct site but when I select AutoFill nothing happens. It only happens in Safari (Firefox works OK). It is only a few sites, but it is the few I use multiple times a day. I've already tried reinstalling the Extension but still fails to fill.


1Password Version: 1Password 7 Version 7.6.BETA-2 (70600002) 1Passwor
Extension Version: 7.6
OS Version: 10.15.5
Sync Type: 1 password Cloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @dserrone!

    Can you please let us know the URL where this is happening, so we can test it here too? Thank you!

  • https://banking.commercebank.com/CBI/login.aspx. Here is what is funny about this- I discovered this morning if I open the 1 Password app on my MBP and choose this from there and ask for it to open and fill it will fill. Yet, from the extension or the mini it refuses to fill.

  • Also, I 4got to add on https://webmail.earthlink.net/wam/login.jsp?x=-36153805&x=-646603446 which is my email --it never fills.

  • ag_anaag_ana

    Team Member

    @dserrone:

    Thank you for sharing those links. I have tried both websites here and I was able to fill both of them without problems. Are you able to fill your credentials if you try using the Cmd+\ keyboard shortcut while you are on the login page of those two websites?

  • No it doesn't fill. What happens with. Cmd\ is it opens the extension showing choices for that login URL. My wife and I share that Earthlink Email, along with my daughter and grandsons. So I am permitted to choose which account I want filled when I use Cmd\ - but still not filling. Now with the other site, my Commerce Bank account, that does fill with Cmd. Oh BTW thanks for you assistance.

  • ag_yaronag_yaron

    Team Member

    Hey @dserrone ,

    I noticed you are using the latest beta version of 1Password. We recently released a big update in the beta channel that changes how 1Password's autofill logic works, so you might need to re-save some existing logins in order for the new logic to get a login item in the new structure it may need on specific websites.

    Please try this:
    1. Get to one of your websites where autofilling doesn't work.
    2. Save a new login manually: https://support.1password.com/save-login-manually/
    3. Test and see if that new login does autofill correctly. If it does, then feel free to delete the old login that no longer works.

    The other solution would be to install the stable version of 1Password, but that is only temporary as the beta version will soon be released on the stable channel.

  • Just tried that. Deleted old Signins emptied trash restarted 1Password and then filled out the page and Saved as New Login. When I went to that Login on earthlink after resaving as new that Sign I found that 1PW only saved what I named that login and the website URL (that's true for all three Earthlink accounts). It didn't save the Login ID and/or PW. So I edited new card filling in that info and saved. Still my email accounts do not Auto fill. I've been using 1 Password for years and have turned all my family and friends onto it. I know how to use it pretty well. This is the 1st problem I have had. I can still copy and paste the ID and PW into my Earthlink email accounts, but it would be nice if the auto fill worked. Again it works fine with FireFox the problem is only with Safari. But I prefer Safari as my browser. Again, thanks for everyones aid - I know this may be trivial compared some the stuff you need to work on.

  • ag_yaronag_yaron

    Team Member

    Thanks for the additional info @dserrone ,
    This issue is not trivial at all. We released a major change in how 1Password autofills in the latest beta, so your feedback is most appreciated.

    I forwarded the issue to our developers, hopefully that will be fixed in the next update. For now, you can either copy-paste or drag-drop from 1Password into the website, or you can install the stable version of 1Password from our website to get the old autofilling that worked for you. We do hope you'll stay with the beta and keep us posted about any other issues you may find though :chuffed:

  • Hey I just updated to the latest Beta and all is well. what ever the glitch was it corrected itself in this new Bata version. Thanks for you wonderful and gracious help.

  • ag_michaelcag_michaelc

    Team Member

    Hi @dserrone. I'm glad to hear things are working properly again in the newest beta. :smile: On behalf of Yaron, you are very welcome.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file