Client setup on RHEL

Reference from :
I am trying to perform below steps on RHEL

gpg --receive-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
gpg --verify op.sig op

Getting below error :-1:
[prompt ]# gpg --receivekeys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
gpg: invalid option "--receivekeys"

When I tried the setup for mac it worked fine.

[prompt]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)

1Password Version: 1.1.0
Extension Version: Not Provided
OS Version: RHEL
Sync Type: Not Provided


  • ag_anaag_ana

    Team Member

    Hi @mohitora!

    Our documentation page on the CLI says to use the option named --receive-keys. It looks like you are using --receivekeys instead, so can you please check if things work for you with the correct spelling?

  • Hi @ag_ana ,

    Actually I tried both options, here is with other one.

    [webapp]$ gpg --receive-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    gpg: invalid option "--receive-keys"


  • ag_anaag_ana

    Team Member


    Thank you for the confirmation. I have asked a colleague, and he suggested to try the --recv-keys option on RHEL. Does that work for you?

  • mohitoramohitora
    edited June 19

    Yes its working, but struck on sign in command now :(

    [onepassword-api]# gpg --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
    gpg: requesting key 2012EA22 from hkp server
    gpg: /root/.gnupg/trustdb.gpg: trustdb created
    gpg: key 2012EA22: public key "Code signing for 1Password [email protected]" imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)
    [onepassword-api]# gpg --verify op.sig op
    gpg: Signature made Fri 12 Jun 2020 04:41:16 AM CDT using RSA key ID 2012EA22
    gpg: Good signature from "Code signing for 1Password [email protected]"
    gpg: WARNING: This key is not certified with a trusted signature!
    gpg: There is no indication that the signature belongs to the owner.
    Primary key fingerprint: #### REMOVED ######

    [onepassword-api]# mv op /usr/local/bin/
    [onepassword-api]# op --version
    [onepassword-api]# op signin
    [ERROR] 2020/06/19 10:04:28 Can't sign in. Enter your full sign-in address.

    The same thing worked on my Mac machine but not on RHEL.

  • Matthew_1PMatthew_1P

    Team Member
    edited June 21

    Hey @mohitora, I'm able to reproduce this on Fedora using v1.1.0 of op, but I don't have a Mac on hand to test it out on. I tried an older version of op, and it doesn't seem to be reproducible on v1.0.0. Just to check, is your Mac still running v1.0.0 of op by any chance? That would explain the difference in behaviour.

    I've passed this on to our development team so they can take a look too. Thanks for letting us know! :+1:

    ref: dev/b5/op#804

  • mohitoramohitora
    edited June 22

    Hey @Matthew_1P

    Above is the screenshot, on the left side is MAC(op version is 1.0.0) and on right its RHEL( op version is 1.1.0)

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @mohitora! It seems like the difference in the op version could really have something to do with this. I will add your findings to the internal issue we are using to track this :+1:

  • Here is the signin difference between the both

  • ag_anaag_ana

    Team Member

    Thank you!

  • felix_1pfelix_1p

    Team Member

    Hi @mohitora . This was an error on our side and we have release version 1.1.1 of the command line tool to fix this issue. I'm very sorry for the inconvenience!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file