1passwordX in Chrome (Mac), both beta and non-beta doesnt seem to be pushing updated passwords

When I update passwords in my phone, they get synced to the cloud but passwordX on the desktop doesn't see the updates until I lock/unlock or close Chrome. Is that an expected behaviour?

1Password Version: 7.6BETA3
Extension Version: 1.20.4 (1PasswordX)
OS Version: OSX 10.15.5
Sync Type: 1Password.com
Referrer: forum-search:1passwordx sync


  • kaitlynkaitlyn

    Team Member
    edited June 2020

    That doesn't sound right, @_jaar. I'm really glad you reached out to us.

    I'm wondering if you could try creating a new item in 1Password X and checking if you can see the item in the 1Password web app as well as your phone. Here are the steps for creating an item in 1Password X:

    1. Visit a website such as https://twitter.com/login.
    2. Enter "test" in both the username and password fields.
    3. Click Save in 1Password underneath the password field.
    4. Click Save.

    Go ahead and check on https://my.1password.com along with your phone and let me know if the new item shows up within a few minutes.

  • Thank Kaitlin

    I tried the above, creating a new login item in 1Password web app does not push an update to either the 1PasswordX extension or the Mac desktop app but it does immediately show on the iPhone app - behaviour is not always consistent, I repeated the test 4 times and half of the times I did get an instant update on both X and Mac.

    Weirdly enough, any updates in the Mac app always show instantly in 1PasswordX.

  • ag_michaelcag_michaelc

    Team Member

    Do you have any sort of networking software on your Mac, @_jaar, whether that's antivirus, firewall, antimalware, proxy, VPN, system-wide ad blocker, or anything else like that?

    You mentioned you tried what Kaitlyn suggested, but it sounds like you did a different test than what she mentioned, which was about creating an item in 1Password X, not on 1Password.com. What were your results there?

  • I did also create the items in 1PasswordX but that takes me to the Mac app (I have the integration with the app on) - but in any case without that integration creating new items in 1PasswordX just takes me to the 1Password.com. My problem is really pushing changes into 1PasswordX for changes done outside of the extension.

    I have Sophos antivirus installed, but that doesnt really have a firewall as far as I know. No VPNs active.

    Thanks for your help!

  • ag_yaronag_yaron

    Team Member

    Hey @_jaar ,
    Thanks for the update.

    1Password X works directly with your 1Password.com account and shows its content, so anything on the server is visible in 1Password X, which is why we are performing these tests here - to find out where things gets stuck. For the purpose of testing here, from now on, please do disable desktop app integration when trying our suggestions so we can isolate 1Password X, 1Password 7 for Mac and your iPhone.

    Please try the following:
    1. Create a new login on your iPhone app (and make sure you save that new login on a vault that exist in your 1Password.com account, such as the "Personal" or "Private" vault).
    2. Go to https://my.1password.com and sign in, then check if that new login is there.
    3. If it is there, check 1Password X on your Mac and see if the new login is there.

    Let us know the results.

This discussion has been closed.