iOS local WLAN sync stuck on "Syncing..."



  • BenBen AWS Team

    Team Member

    Hi @pentool

    I have tried to search on this issue but only found one back from 2016.

    Sorry about that. The search on the forum isn't always the most accurate. I've merged your thread with another on the same subject.

    It seems the issue is a bug in 1Password for iOS. We're hoping to have that fixed up soon, though I couldn't say exactly when.


  • As we say on the Apple Discussions Forum: "I have this question too."


  • brentybrenty

    Team Member

    @rrustema: I'm sorry for the inconvenience. I've merged this into the existing discussion in the iOS category since this is not a Mac issue. As Ben mentioned in the post you replied to, it's something we're working on.

  • @Lars , @Ben , I'm still having problems. It's back to not synching and not updating the sync date. I tried the test where I create a new note on the desktop and sync. I see the iPad automatically trying to sync when I make that change. But the note doesn't show up. Similarly, I've added and changed many logins from both devices (desktop and tablet) and none have appeared on the other device.

    iPad Pro running iOS 13.1.3 and 1Password 7.4.2
    Mac mini running MaOS 10.14.6 and 1Password 6.8.9

  • BenBen AWS Team

    Team Member


    Have you tried all of the troubleshooting steps in this guide?

    If you're having trouble using the WLAN server

    If so the best I could suggest in that case is switching to a more reliable sync method:

    Sync your 1Password data


  • Yes, I've done all of this stuff multiple times. And I just checked and adjusted my privacy settings and tried again. no go. It says it synched, but it hasn't. The WAN sync has been problematic for months now. Not synching, synching but reporting it incorrectly, reporting it synched but not actually doing it, .... I've been using 1Password and properly synching my information across devices for years and years. I have a hard time believing this is suddenly user error on all of my devices. The only other sync options covering mobile devices are cloud-based, which I'm not considering.

  • BenBen AWS Team

    Team Member
    edited October 2019

    The issue where the sync state is not correctly reported is a bug that'll be fixed soon. Other than that we have not been able to reproduce any reported issues with the WLAN Server. It is working here. If there were a bug in the operation of the sync I would think we would have a lot more people reporting issues unresolved by the troubleshooting guide.

    Unfortunately WLAN is the most technically complex option we offer that is affected by the most outside variables. It simply isn't going to work in every environment, and there are more reliable options.


  • With 1Password macOS 7.4.2 and 1Password iOS 7.4.5 this issues seems to have been fixed. Perfect! 👍

  • BenBen AWS Team

    Team Member

    Thanks for the update @daniel110928. Glad to hear it is working better now. :)


  • Weird, I'm on macOS version 7.3.2 (70302004) and it's telling me there are no updates, despite my being able to download 7.4.2 from the 1Password website. Is something wrong with the update checker?

  • BenBen AWS Team

    Team Member


    I do vaguely recall some updater issues in the past though I'm not finding any posts about it off-hand. Please try installing 7.4.2 from our website and see if future updates arrive as expected.



  • Unfortunately, I'm not seeing the good results @daniel110928 is seeing.

    I'm also using 1Password macOS 7.4.2 and 1Password iOS 7.4.5, and after a WLAN sync finishes, the 1Password UI continues to display "Syncing...". I.e., the 1Password UI never indicates that the sync has finished.

    However, it's possible that this is because I'm running older versions of macOS and iOS. Specifically, macOS 10.12.6 (Sierra), and iOS 12.4.1. Maybe with a newer version of macOS (e.g., Mojave) or iOS (iOS 13), the problem does go away.

  • ag_anaag_ana

    Team Member


    It is possible that the OS version could be the reason why this is happening, if that is the only difference in your two setups. Please let us know if you still see this after you update :+1:

  • Good news: this problem seems to have been fixed with the version 7.6 update of the macOS 1Password app.

    After updating to 1Password 7.6 on my Mac (under macOS 10.12.6 (Sierra)), my iOS versions of 1Password on my iPhone and iPad (version 7.5.3 on both devices) now correctly display "WLAN" when syncing finished, 99% of the time. (The one time the problem persisted was when the syncing process ran longer than normal on the iPad, as opposed the normal, short "incremental" sync that I usually get.)

    I'm not completely sure the fix occurred due to the macOS 1Password update; I also recently updated both iPhone and iPad to iOS 13. But I think the problem was still occurring after the iOS 13 update for a couple of weeks; the macOS 1Password 7.6 update occurred just this last weekend.

    So, as far as I'm concerned, this bug is fixed. My thanks to the Agilebits development team for fixing it!

  • ag_tommyag_tommy

    Team Member


    Thanks for letting us know things are working better. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file