MFA Option Not Showing Up for GitLab

We are running GitLab, and have turned on MFA as mandatory. It's working fine with Google Authenticator.

However, I want to use the 1Password MFA. But the login does not prompt/allow me to use MFA like it does for other sites.

Is there a way to make 1Password allow a MFA?

Thanks in advance.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:MFA gitlab


  • BenBen AWS Team

    Team Member

    Hi @dale_courtney

    I'd be happy to help with that. Generally, for most services, you would either need to have saved the TOTP secret from when you originally set up Google Authenticator, or you would need to turn MFA off and back on in order to save said secret now, to add it to 1Password. You can add the same secret to both apps (both 1Password and Google Authenticator), but you'd have to have the secret on-hand to do so. Services typically won't give you that secret except when you are setting up MFA. The secret often comes in the form of a scannable QR code, which could be printed or saved digitally.


  • Thanks, Ben.

    It's my fault that my question was unclear.

    Normally in 1Password, I get a red alert at the top that MFA is an option for certain sites. That is not showing up for GitHub, so I cannot add it there.


  • BenBen AWS Team

    Team Member

    I see, @dale_courtney. Thanks for clarifying. You don't need the Watchtower alert in order to add the TOTP secret to 1Password though. Instructions can be found here:

    Use 1Password as an authenticator for sites with two-factor authentication

    Is your company self-hosting GitLab, or are you using the hosted version? If using the former that would explain why Watchtower didn't flag it.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file