Import via CSV with Tags?



  • I had to go back in and add Temp to the blank login and password fields in my spreadsheet and then i re-imported it and it worked. FYI. Thanks so much for your help!!

  • MrCMrC Community Moderator

    That's good news @Shannakae .

    Enjoy 1Password!

  • Hey, i just realized that some of my fields still ended up in notes. e-mail: & login username.
    I do have Login Username and E-mail capitalized in my spreadsheet. I am not sure why it went to lower case and put it in the notes? Can you help me? Thanks!

  • MrCMrC Community Moderator
    edited August 10

    Hi @Shannakae

    Each 1Password category has a set of stock fields. Your e-mail is not one of those stock fields. The converter attempts to fill those stock fields, and by default, will place any other fields, that are foreign to 1Password, into the Notes section of an item. So, your E-Mail, Product Key, Phone, etc. fields all get placed into Notes.

    The converter suite can place those foreign fields into 1Password custom fields, by using the --addfields option:

    and after importing the converted file:

    Now, as to why your Username Login field did not get placed into the Login's username field, this puzzled me and should not have happened, so I went back and looked at your data from the sample file you sent me:

    Aha! The screenshot shows the (hexadecimal) values of your data file. The c2 a0 that I've highlighted is a Non-breaking Space. It is present just before the L in your Login Username column label. That should not be part of the column label, so it must be present in your original spreadsheet. Screenshots 1 and 2 above show the conversion / import after I removed this Non-breaking Space.

    And finally, as to the lower-casing. 1Password uses lower case for stock field labels, and so the converter suite honors this convention by doing likewise.

  • Thanks! I will try this out when I get back to the oofic😁

  • Brilliant! It all worked! Thans so much! I copied your line of code but changed the file name obviously. It was saying file not found when i had ~ before/filename but i changed the ~ to ../fileaname and it worked. Honestly, i am not sure what i was doing or how that worked but i tried it and it worked. HAHA

  • MrCMrC Community Moderator

    @Shannakae ,


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file