Many sites lately won't autofill

I've noticed lately that more sites won't autofill that used to.

I generally use Firefox on Android and mac, but I also went to Chrome for one just to try it out.

I'm also finding that more and more the email/username won't autofill even if the password does.

Is there an easy way to send you a url every time I notice the issue? It seems like this isn't the best medium for reporting every single website that isn't working properly.

For ADP workforce now administrator login won't fill in anything https://ewallet.adp.com/auth/enroll/adpLogin.faces?TYPE=33554433&REALMOID=06-0009729e-cfc0-1f1b-aeeb-b0290b010092&GUID=&SMAUTHREASON=0&METHOD=GET&SMAGENTNAME=-SM-c+U7p1p4zqe2Poe5bAmruRfYYDFxrxYIC6JYQpgH6aHcdehO94V+8funBrHPr+J7&TARGET=-SM-https://workforcenow.adp.com/theme/admin.html

For Simplii bank the password won't fill in. https://www.simplii.com/en/home.html

I completely understand autofill is a moving target with constantly changing websites, I just think reporting an issue should be a click in the app when you're on a website.


1Password Version: Not Provided
Extension Version: 1.21.2
OS Version: os x 10.15.5
Sync Type: Not Provided
Referrer: forum-search:website auto fill

Comments

  • kaitlynkaitlyn

    Team Member

    Hi @passwordsbeegone! Thank you taking the time to report some filling issues you've been running into lately. I know it takes a bit of work, and I appreciate it. I'll pass along your feedback regarding reporting an issue being as easy as a click in the app when you're on a website. I'd love to see that implemented at some point in the future as well. :)

    Now for the filling issues, I see what's going on with the ADP site. The 1Password icon isn't appearing in the username field, making it difficult to save an item on that page. In fact, I tried to force 1Password X to save a new item, and it didn't recognize any fields on the page. I took a closer look at the code, and I realized that this is all 1Password X has to go off of for the username field:

    <input type="text" value="">

    All that's to say is that ADP isn't making it easy on us when it comes to designating the username field. I'll go ahead and get this issue reported to our developers so we can work on improving the behavior. Again, thanks for getting it on our radar!

    For Simplii's website, I tried saving a brand new Login item, and it filled as I'd expect it to. I'd like to have you give that a try and see if you get any different results. Here's how I did it:

    1. Visit https://www.simplii.com/en/home.html and click the Sign On button.
    2. Type (or copy/paste) your card number and password.
    3. Before pressing enter, click Save in 1Password underneath the password field.
    4. Name the new item something different to distinguish it from your existing item. I generally just put the word "new" in the title.
    5. Click Save.

    Does your new item fill any better than your last one? Let me know what you find.

    ref: dev/core/core#2546
    ref: dev/projects/customer-feature-requests#231

  • Thanks Kaitlyn, Gah, that's no much to go on for the ADP site. I appreciate this is almost always the web developers fault and not 1password.

    I tried simplii again, and I realized the issue is only if you save the card. If no card is saved it fills in fine, and I don't really need to save the card because I have 1password, so all good there.

    Thanks for your time

  • kaitlynkaitlyn

    Team Member

    @passwordsbeegone – I'm in no way blaming the web developer here; I'm sure they're doing the best with what they know. It keeps us on our toes, but you said it best, autofill is quite the moving target.

    I'm glad to hear you ended with a working item on Simplii as well. If you do come across any other sites that aren't filling properly, feel free to either report them here or shoot an email to [email protected] We're always happy to investigate. It'd be impossible for us to test every site ourselves, so we genuinely appreciate the reports.

    You're very welcome! Take care, and have a great rest of your week. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file