iOS autofill search doesn't work on first try

dgbeecherdgbeecher
edited August 20 in iOS

Very frequently, I have trouble searching 1Password on iOS when triggering search through the iOS autofill feature. This problem arises only for apps that are not clever enough to provide an identifying URL (ie, there is no "for sampleurl.com – 1Password / username" text below the login screen and above the keyboard). Rather, it occurs with apps for which I have to search my vaults for the correct login info. The problem is that search doesn't work at first; I need to tap "Cancel" and try again. I run into this problem probably a little less than half the time that I encounter this situation. So, very frequently!

Let me describe more specifically what happens -- note that the problem arises at step #6 below.

  1. Open app with a login screen
  2. Tap "Password" right above the keyboard
  3. 1Password slides up
  4. Tap "Search All Vaults" at the top of the screen, above the list of all my passwords
  5. Start typing my search
  6. Notice that the list of passwords is not getting filtered (ie it doesn't change at all)
  7. Tap "Cancel" next to the search field
  8. Tap "Search All Vaults" again
  9. Start typing my search
  10. Almost always it works on this second try -- ie, the list of passwords gets filtered so that I can find my desired login

Please let me know how I can troubleshoot or if there is more information that I can provide to help find a fix. This problem has been persistent for a while, probably > 6 months. I'm on iOS 14 beta 5 right now, but I had this problem on all the non-beta iOS 13 releases as well. Thanks for looking into this!


1Password Version: 7.6.2
Extension Version: Not Provided
OS Version: iOS 14 beta 5
Sync Type: 1Password.com

Comments

  • ag_anaag_ana

    Team Member

    Hi @dgbeecher!

    I have tried this a few times but I have not been able to reproduce this issue yet. I am also using 1Password 7.6.2, but I am on the latest version of iOS 13. Although you said that this happened to you also on iOS 13, so that's probably not an important difference.

    Would you perhaps be able to send us a short video of this behavior?

  • Hello @ag_ana! Thanks for your message. I just took a video of the issue and sent it to your support email. (I didn't want to share it on this forum.) Please let me know (either here or by email) if that was helpful and what any next steps might be.

  • ag_anaag_ana

    Team Member

    @dgbeecher:

    Thank you! I confirm that I have managed to locate your video in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: LHX-64394-682

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file