AutoFill / fingerprint on Android 10 / Xiaomi Mi9t

edited August 10 in Android

I recently updated my phone and now I'm having some issues with AutoFill and 1Password: if 1Password is running in background (vault not locked) everything is working fine, and credentials get filled in. But if not, the autofill prompt comes up, I click on it and then I get asked for my fingerprint, the fingerprint will not be recognized. FOD lights up, so it's not a hardware issue and logcat says it's able to find multiple identical lines but theres no match with a saved fingerprint. If I start 1Password directly or any other app using fingerprint everything works fine. Even sometimes after closing 1Password and then using autofill with my fingerprint it's working for a short periof of time.

What I already tried:
1) completely uninstall and reinstall 1Password
2) deleted all fingerprints and re-added them
3) tried the latest 1Password beta
3) tried another password safe just to make sure it's not my phone and there AutoFill is working fine

1Password Version: 7.6.2
Extension Version: Not Provided
OS Version: Android 10, patch level july 2020
Sync Type:


  • periperi

    Team Member

    Hi @Rene87. Thanks for reaching out. Could you let me know what happens when you see the Biometric Unlock prompt? Does it jiggle or otherwise respond at all, or does it just stick there?

    Also, do you have Lock on exit on in 1Password's Security settings?

  • Hi @peri, as my phone has a in-display fingerprint sensor, the area for recognition lights up when placing a finger on it. According to logcat it recognizes the 'lines' of my finger, but cannot match them to a saved fingerprint. I know, that sounds like an issue with my phone. But why is it working then within apps and why is autofill working for other apps... really strange.

    And yes, I've tried switching this setting. If it's disabled and 1Password stays in background, during autofill the biometric unlock prompt will be skipped and I'm able to fill in the credentials. As soon as it's enabled I get the biometric unlock prompt and my fingerprint doesn't get recognized.

  • periperi

    Team Member

    @Rene87 Due to the breadth and depth of variety on Android there are often device manufacturers pushing the boundaries of what is possible on Android. Because Android is an open platform this often means that they create their own 'exclusive' ways of doing things. Should these methods be later adopted by Google into the core feature set of Android then there will then be another way of doing this particular thing - let's call it the 'official' way. The trouble is that manufacturers don't often go back and update older devices using the 'exclusive' method to use the new 'official' method. This is the current state of biometric unlock (fingerprint unlock went through the same rigmarole several years back).

    Here at 1Password we don't support the 'exclusive' unlock methods and only support the 'official' method. To add another little wrinkle to this, the new 'official' method rates different unlock methods, and 1Password will only support unlock methods considered strong. As there are a variety of ways of doing Fingerprint Unlock (some of which are pretty basic), it may be that Fingerprint Unlock works with 1Password on some apps and not others. Since you're not having the same issue with other apps, it's likely they're not using the same crypto that we are.

    As to the issue you're having, I've heard this same issue from other Xiaomi users. I've created an issue internally for our developers to look into. In the meantime, I'd recommend turning Lock on exit off to make filling easier.

    ref: dev/android/onepassword-android#788

  • @peri Thank your for the detailed explanation.

    Just two questions/things to add:
    1. Why is it working then within the 1Password app and only making trouble with AutoFill?
    2. Why is it working sometimes and sometimes not? During the weekend my phone got a small update und after AutoFill was working for a short time and stopped again without doing anything? Maybe I'm wrong, but I'd conclude that differences in regards of the used crypto libs should always lead to the same behaviour?

  • ag_preetag_preet

    Team Member

    Hi @Rene87, I'm not sure why it's only partially working for you, as Peri said, this is an issue that we've seen for Xiaomi devices which we're still looking into.

    You can try refreshing your phone and 1Password settings, make sure you have your Master Password for 1Password before attempting this.
    1. Disable fingerprint unlock in 1Password
    2. In your phone settings, delete your saved fingerprints and turn off fingerprint unlock
    3. Restart your phone
    4. Turn your phone fingerprint unlock on
    5. Save your fingerprints again
    6. Reenable fingerprint unlock in 1Password

    To give us a better idea of how 1Password is behaving on your device, could you email in a diagnostic report, please?

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected]

    With your email please include:
    Your forum username: Rene87

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

  • Hi @ag_preet, thanks for your help. There was another small update for my phone and my issues seem to be gone. Hope it will stay like this... if not, I'll create the diagnostic log and send it to you.

  • ag_anaag_ana

    Team Member

    Sounds good @Rene87, thank you for the update! And on behalf of ag_preet, you are very welcome :)

  • periperi

    Team Member

    @rene87 I wanted to follow up with you on this. You mentioned that you stopped seeing an issue after an update. Is that still the case, or are you seeing this issue again?

    If you do see this issue again in the future, could you please set your phone's brightness to the max, and let me know if that resolves the issue? Thanks!

  • Rene87Rene87
    edited August 30

    Hi @peri, until now everything is fine, did not have any issues anymore. Asked the dev what has been changed between the versions and he pointed me to that kernel change log:
    Maybe that's somehow useful for you?

  • periperi

    Team Member

    I see. Thanks so much for the update @rene87, and for the link to the changelog. I'm glad to hear that everything is still working properly for you, and I'll keep this in mind in case others report this error.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file