Any way to disable the new lock screen popup?

Hi

With the latest update to 1.21.0, there is now a lock screen popup in form fields when 1Password is locked. It informs users that 1Password is locked and the hotkey to unlock it (tagged as {!1563} in the release notes, whatever that refers to?). Is there some way to disable that? I've looked through the settings and checked forums etc. without finding anything.

The popup is quite large/intrusive and obscures several fields in some forms. I don't keep 1Password unlocked when I don't need it, so I already know the app is locked. I'm also aware of the hotkey and use it. I'm guessing that for most users the popup doesn't provide any useful information. Instead it just gets in the way on pages where I don't use 1Password for credentials (e.g. developer environments). I see it doing a service for new users, but it's just in the way for me. It would be really nice to have a setting to disable it.

Best regards
Mathias


1Password Version: Not Provided
Extension Version: 1.21.0
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @matka,

    I can definitely see how this popup interrupt your workflow in development environments. Do you happen to have an example page available publicly so we can investigate the field(s) in which 1Password pops up? We've recently improved it so that 1Password won't show up in pages that do not contain a password field and has the autocomplete=off tag, so I'm wondering what might be triggering 1Password X there.

    If you're worried about sharing it publicly, we can definitely move the conversation to email, so let me know.

  • VedranVedran
    edited August 31

    Hello!

    I have the same issue (didn't want to start another thread for it). One of the main reasons for choosing 1Password over the password manager that I used before was that it did not bother me on forms with the popup but just had a nice, unobtrusive icon on the side of the input field. The problems started when I started to use autocomplete attributes in the forms that I develop so the popup could've been there from the start but I just didn't stumble upon that many autocomplete forms?
    Could be, but either way is there an option, or if there isn't one can it be added to the settings that could disable the popup and just leave the icon on the side like it used to be, regardless of fields having autocomplete attributes?

    Or if not that, then at least an option to disable 1Password on localhost? Chrome only give the options to either:
    1. disable an extension on all sites and have it enabled by clicking on it (which reloads the page)
    2. enable on a particular site
    3. enable on all sites

    Now that I look at it I might be asking too much and will probably have to find a work-around. But is there a chance of having any of those settings added in the (near) future?

  • ag_yaronag_yaron

    Team Member

    Hey @Vedran ,

    You can turn off 1Password's inline menu while you work on localhost:
    1. Right click the 1Password extension icon on the top right of your browser and select "Settings".
    2. Scroll down to the "Autofill" section.
    3. Disable both features there.

    That will allow you to work without interruption. When you need to autofill anything, click the extension icon on the top right and autofill from there.
    When you need it, you can turn the autofill features back on which will get 1Password back into the fields on websites you visit.

    I hope this solution will improve your workflow drastically :)

  • Very nice! Even (just) the logo button in fields appears now so I'm back to the previous workflow. Thank you very much, @ag_yaron :smile:

  • ag_yaronag_yaron

    Team Member

    You're most welcome @Vedran :+1:

  • Hi @ag_yaron

    The forms I'm thinking of are bona fide login forms, so the question is not about false positives.

    Disabling the "Show autofill menu on field focus" setting does make the popup go away when 1Password is locked, but that obviously also makes the autofill menu go away when 1Password is unlocked. The autofill menu is very convenient when I have 1Password unlocked, so I'd like to keep that.

    I.e. I want this popup:

    But not this popup:

    You can't tell, but there are links underneath that popup that may be useful. Okay, maybe not those particular links on that particular login form, but on other forms there are elements I want to access which are obscured by the popup.
    For example I have a vast number of the form shown below on different servers, which I'm not using 1Password to store credentials for (because they're trivial and transient):

    I think toggling the setting back and forth is too cumbersome to be a tenable workaround. I have parallel workflows that respectively need and don't need 1Password, so no setting works in all cases.

    In short, with the 1.21.0 behaviour, the new 1Password popup gets in the way when 1Password is locked. The popup doesn't really serve any useful purpose. The small elegant icon on the right side of the fields already show whether it is locked or not, and the hotkeys are not difficult to remember. I'm not sure what the popup is good for except for new users who are just starting to use 1Password, and they too will only need it in the beginning.

    I'd really rather not disable the autofill menus in the settings just to avoid the popup when 1Password is locked -- I'd much rather have a third separate setting under the "Autofill" section that can disable just the locked popup.

    Best regards
    Mathias

  • ag_yaronag_yaron

    Team Member
    edited September 1

    Hey Mathias,
    Thank you kindly for clarifying and presenting examples.

    Firstly, as a temporary workaround, you can simply press ESC to dismiss that popup (whether 1Password is locked or not), and it will clear the way immediately. Hopefully that will improve your workflow for the time being.

    Secondly, we've indeed added the notification that 1Password is locked for users who are not as tech savvy (and yes, often these are new users). It has been of great help to them so far, but we're keeping track of how it affects everyone, so your feedback here is greatly appreciated.

    I'll forward it to our development team and see if there's a way to make it less intrusive in the future. Many thanks for bringing that up!

  • Hi @ag_yaron

    Cool, thanks! I will make do with disabling the autofill in settings for now, since I find myself dismissing the locked popup far more often than using the autofill menu in daily workflow.
    Having the locked popup enabled by default and a setting to turn it off will be just fine (rather than changing the popup itself).

    Best regards
    Mathias

  • ag_yaronag_yaron

    Team Member

    Sounds good for now :+1:

  • jameshowisonjameshowison Junior Member

    +1 for adding the option in settings to remove the pop up. The little icon in the fields is much better for me.

  • +1 for me - this is a dealbreaker for me

  • ag_yaronag_yaron

    Team Member

    Thank you guys for chiming in and supporting this feature request!

  • +1 for adding the option to remove the pop up. It's too large and intrusive and as others above pointed out, it auto-covers important links on login pages. I'm not quite at "dealbreaker" as @davidwain1 is above, but it's close.

    I get the new user perspective, but it really feels like it should be handled with onboarding and education, rather than forcing the pop up on EVERYONE. ALL. THE. TIME.

  • ag_anaag_ana

    Team Member

    Thank you for the feedback as well @JamesThompson2004 :+1:

  • Any update on this? We're now getting close to finding another solution. 100% of the time the 1Password box competes with and overlays Edge Chromium's password pop up boxes.

  • ag_anaag_ana

    Team Member

    Not yet @JamesThompson2004. I wonder however if you have tried the suggestions by ag_yaron above already, and if they helped?

  • As I've stated elsewhere, this pop-up is particularly annoying when you have both 1Password and 1PasswordX installed...

  • Hey all. We've made a change in the latest 1Password X releases (stable and beta) that I think y'all will be happy with:

    If 1Password is locked, the inline menu no longer shows automatically when focusing a field. {#2686}

    If you're not seeing this right away, you can check for updates to 1Password X manually, or this'll hit your device in the near future. :smile:

  • @ag_yaron @ag_ana @ag_michaelc Indeed, that is very pleasant. Thanks to you and the team! :)

  • ag_yaronag_yaron

    Team Member

    We're very happy to hear it @matka . :+1:

  • It would be nice to fill in directly the master password in an input field instead or in addition of the notification to press the shortcut. I'm a 'mouse' guy so now, when I see the popup I have to go to the upper right of my screen every time to fill in the Master Password....
    Any change to make it possible?

    Regards,
    Benny

  • ag_yaronag_yaron

    Team Member

    Hey @Bennyd ,

    Unfortunately, that would be a security threat since websites will be able to imitate that popup and will ask you to input your Master Password, then steal your password. We thought about it but there's no safe way to do what you're asking here. :angry:

  • Okay, I'll understand.

  • ag_yaronag_yaron

    Team Member

    We're working on some other improvements that would hopefully make unlocking 1Password easier, so keep your apps up to date and stay tuned!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file