Fingerprint not working: javax.crypto.IllegalBlockSizeException

edited August 13 in Android


I had my 1Password app configured so that I can open my vault using my fingerprint. It has been working smoothly for a long time. But today I open the app and it tells me I cannot use the fingerprint to open the vault. Then I enter my master password. And when I go and try to re-enable the fingerprint feature I have the following stacktrace:


(This is not the complete stacktrace, as I was unable to take a screenshot or select the text of the dialog. I reproduce the first and last method calls by hand.)

Best regards

PS :

Running Android 7.0 and 1Password indicated as up-to-date by Google Play.

1Password Version: 7.6.2
Extension Version: N/A
OS Version: Android 7.0
Sync Type: N/A


  • N_Z_LN_Z_L
    edited August 13

    Plus, when I open the vault using my master password it says “the master password has been modified” as a gray popup on the bottom of the UI that disappears by itself.

    After a reboot, I am able to re-enable the fingerprint feature and there is no more stacktrace.

  • ag_anaag_ana

    Team Member

    Hi @N_Z_L!

    Thank you for the update! Have you managed to reproduce this again even after a reboot?

  • I actually am also having this problem on my cell phone. The bio works on my tablet with no trouble, but I receive the above error on my Android phone. I have rebooted, uninstalled and reinstalled the app, with the same outcome. Any guidance would be appreciated!

  • periperi

    Team Member

    Hi @dpgaspar Can you please disable your Biometric Unlock settings on the device, then re-enable them? Once you've done that, are you able to turn Biometric Unlock on for 1Password?

  • I use a customized Samsung galaxy s7 edge and I'm having trouble with the app downloaded from Play Store. I can't enable the fingerprint unlock option and I can get an error message just like the guys mentioned above. I am willing to reproduce the problem at any time (UTC+8) and I can also offer you the error message. Looking forward to get a response.

  • periperi

    Team Member

    Hi @Leo_Maxwell. Can you clarify what you mean by a customized Samsung Galaxy S7 Edge? Are you using a custom ROM on the device, or is it rooted?

    We have noticed that some custom ROMs change the OS in such a way that we're not able to workaround this error.

  • Well it's now running Pixel Experience and you can see it obviously that this ROM is just like its name, a pixel-like ROM. Rooted. It's based on AOSP without many changes and I'm quite sure it won't change such a critical system behavior. I believe it's a 1Password app problem and I can see similar posts complaining this problem on Samsung models. As a geek myself, I wonder if this problem is related to Samsung things. Thank you for your work for our users.

  • periperi

    Team Member

    @Leo_Maxwell Did you try the steps mentioned earlier in the thread, such as disabling biometric unlock on the device, uninstalling 1Password, re-enabling biometric unlocking and adding your fingerprints, and reinstalling 1Password?

  • I already tried to re-enable biometric unlock in the Settings and re-configure my fingerprints and neither worked. I didn't try re-install the 1Password because it's kind of complicated to configure my account in a brand new app. But I'm more than willing to try it if necessary. Looking forward to having your response.

  • ag_preetag_preet

    Team Member

    Hi @Leo_Maxwell!

    Let's try refreshing your phone and 1Password settings a little differently before reinstalling if it's easier for you. Make sure you have your Master Password for 1Password before attempting this.

    1. Disable fingerprint unlock in 1Password on your Android device
    2. Delete your saved fingerprints and disable fingerprint unlock in your phone settings
    3. Restart your phone
    4. Reenable fingerprint unlock in your phone settings
    5. Save your fingerprints again
    6. Reenable fingerprint unlock in 1Password

    Let us know how this works for you. :)

  • I'm having this same issue along with many more as i have never used an android in my llife until now...

  • ag_preetag_preet

    Team Member

    Hi @CryptoGeex,

    I'd like to ask you to create a diagnostics report from your Android device: Sending Diagnostics Reports .

    Attach the diagnostics to an email message addressed to [email protected]
    With your email please include: A link to this thread: and your forum username: CryptoGeex.

    Afterwards we can talk about this in detail and the other issues you're experiencing. :)

  • I actually NEED support ASAP, i just got booted out of my vault from an injected pop3 server

  • As in, i could really get some support before my whole system crashes and I lose eveyrything

  • edited September 22

    I just got injected from a POP3 server with sometype of malicous code and as I type am losing my info saved in 1Password

    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Windows 10
    Sync Type: Not Provided

  • ag_preetag_preet

    Team Member

    Hi @CryptoGeex, I'm sorry to hear you're having a security issue, the quickest way for you to get assistance is to email our support team.

    Could you send in your diagnostic report and we'll get back to you as soon as possible. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file