How to use "Visit 1Password.com to Sign In" feature [Snap package bug]

edited September 2 in Linux Beta

Today I installed the 1Password native client for Linux on Xubuntu using the software center. It looks like this is version 0.8.2-1, updated on August 8, from the "Snap Store".

On launching the app, I see an option to "Visit 1Password.com to Sign In" vs. "Enter account details manually".

As I don't particularly enjoy entering the long security key manually, I tried using the "Visit 1Password.com" method but can't figure out how to get it working.

I am currently signed into 1Password.com in my browser (Firefox). I have a family account.

When I click the "Visit 1Password.com to Sign In" button in the app, I get directed to https://start.1password.com/native/signin. It offers "Choose an account to add to 1Password" with my family account shown in a button.

I click my account in the browser and XUbuntu brings up a "Launch Application" dialog. I choose 1Password in the dialog and then select the "Open link" button.

1Password now pops up again with the same page as before, with "Visit 1Password.com to Sign In" and "Enter account details manually" buttons.

Clicking the "Visit 1Password" button again repeats the process.

If, in the browser, I select my account again in Firefox, I just get the same "Launch Application" dialog.

If I click "Still not working?" in the bowser page, I get a step by step:

  1. Copy the sign-in link
  2. Open 1Password

I can copy the link with the button here, but launching 1Password does not do anything special. It just has the same login options as before.

Fully exiting the 1Password app before clicking the account from the browser page does not make any difference.

How is this feature supposed to function? Is it browser-dependent? Am I doing something wrong?

I finally gave up after several tries and just copy-pasted the security key from my browser login and the app seems to load fine, just the browser-based sign-in seems to not be working.


1Password Version: Linux 0.8.2-1
Extension Version: Not Provided
OS Version: Xubuntu 18.04.5 LTS
Sync Type: Not Provided

Comments

  • I tried on another computer, this time running Ubuntu 18.04.5 (i.e. "normal" gnome-based Ubuntu, not Xubuntu this time), with the same result.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @fritzophrenic,

    Thanks for reporting this.

    When you click on the account to sign in via the website, it is supposed to open a window on your desktop that shows the account password view like this:

    Is it possible that that window didn't open in front for you, maybe hidden behind another window? You can try again by attempting to add another account, it'll repeat the process for you, to do this:

    1. Click the account chooser on top left to select Add an Account
    2. Click Visit 1Password.com to sign in.
    3. Your browser should open up, you can click on the same account, it won't affect the data you already have in 1Password as you can cancel the sign-in if it works.
    4. When you click on the account, the application launcher from Firefox should open 1Password for you with that account password view for you to type in. If not, try to use the app switcher to see if there's any hidden window.

    I tested Ubuntu and Xubuntu, they worked fine for me.

  • I had the exact same experience. I also use a 1password family account and firefox, but on arch linux.

  • @MikeT I tried your instructions, starting from a signed-in 1password app (I did not see an account chooser until I signed in).

    The first oddity, is right after choosing "add account" I get prompted for my 2FA code for my existing account. I would not expect a 2FA code to be needed for this but maybe there is some reason.

    Next I see the "Add an Account" window, where I click "Visit 1Password.com to Sign In". This brings up a new tab in Firefox with https://start.1password.com/native/signin loaded. I click on my account there.

    Clicking on that account button loads a page that prompts to open a link in the 1password external app.

    At this point, I have 1 browser window, and two 1password windows showing. My signed-in 1password account, the "add an account" window, and my browser window.

    I make sure 1password is selected and then select the appropriate dialog option to open the link. No further windows open. I still have 1 browser window and two 1password windows. The 1password windows have not changed, I still see the "add an account" window, and the logged in account window. The "add an account" window content has not changed, it still has options only for visiting 1password.com to sign in, or enter account details manually.

    Maybe this only works in Chrome? You said you tested in Ubuntu and Xubuntu, what is your default browser? My other thought is maybe it's a snap package thing; I know those are sandboxed to some extent. But @theOval uses arch. Is the package for arch a snap as well?

    My other other thought is maybe it's because we are both using family accounts, not individual accounts on my.1password.com (or team accounts, for that matter). Did you test with a family account or an individual/team account?

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 2

    Hi guys,

    @the0val, can you confirm if you're using the snap package from AUR? There are snap and deb packages available at the AUR provided by the community there.

    @fritzophrenic,

    The first oddity, is right after choosing "add account" I get prompted for my 2FA code for my existing account. I would not expect a 2FA code to be needed for this but maybe there is some reason.

    After unlocking, the sync will kick off in about 5 seconds, so, you probably got the sync started after bringing up the account sign-in view. This will be improved in future updates including the ability to store the 2FA token, so you're not prompted for it on every app start.

    My other thought is maybe it's a snap package thing; I know those are sandboxed to some extent. But @theOval uses arch. Is the package for arch a snap as well?

    That's a very good thought. I forgot the software store offer snaps too, so I just retested with the snap and I can confirm the issue you're seeing. I'll file a bug report and see what we can do to fix it.

    ref: dev/core/core#2689

  • @MikeT I installed aur/1password, I'm not sure which one that is.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @the0val,

    That's the AppImage, it is likely to have the same limitations as the Snap.

    This is the deb version: https://aur.archlinux.org/packages/1password-bin/ (provided by the community here, not by us yet)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file