1Password recently stopped filling in my userid on the EmblemHealth web site.

The web site URL is https://portals.emblemhealth.com/Members/Login.aspx. 1Password used to fill in my userid and password, but for a while now (sorry I don't know when this started) it only fills in my password, even though 1Password has my userid saved in the database. I also noticed this same behavior on my former employers benefits web site (https://leplb0140.portal.hewitt.com/web/morganstanley/login?forkPage=false).

1Password Version: 7.6
Extension Version: Not Provided
OS Version: MacOS Catalina 10.15.6
Sync Type: Cloud
Referrer: forum-search:userid not being filled in on emblemhealth web site


  • ag_yaronag_yaron

    Team Member
    edited September 9

    Hey @amy_fried ,

    I assume you're using Safari, which is the browser in which I tested these.
    The fix for https://portals.emblemhealth.com/Members/Login.aspx is simple - you just need to save a new login on the page and it should work properly:
    1. Go to https://portals.emblemhealth.com/Members/Login.aspx.
    2. Save a new login: https://support.1password.com/save-login-manually/
    3. Test and see if the new login works correctly. If it does, delete the old login.

    As for the other website, it looks like the username is designed as a password field, so there are two password fields on the page which throws 1Password off a bit. We're working on a fix for that and it should be released soon. For now, you can use the drag and drop method:
    1. Get to the login page.
    2. Autofill the password field with 1Password.
    3. Click the 1Password extension icon to open 1Password's window, grab the username field from 1Password with your mouse and drag it over the username field on the website.

    Let me know if these suggestions helped. :)

    ref: /dev/core/core/-/issues/1439

  • ag_jarekag_jarek

    Team Member

    @amy_fried hi!

    Jarek here from the extensions team. To add on to Yaron's excellent advice above, the issue on the second website (https://leplb0140.portal.hewitt.com/web/morganstanley/login?forkPage=false) is something we've recently fixed up. It is currently filling and saving correctly on the 1Password for Mac beta versions, and that improvement will eventually make its way to the stable release as well :smile:

  • amy_friedamy_fried
    edited September 9

    Hi. Good to know that the Hewitt issue will be fixed. Unfortunately, when I followed the instructions to manually create the login for Emblem Health, that doesn't save anything except the URL. I then tried to create the entry by opening 1Password and creating the new login from scratch. I still have the same issue of no userid getting filled in. Could this be the same issue as the Hewitt portal?


  • ag_yaronag_yaron

    Team Member

    Hey Amy,
    Are you using Safari?

    Here's what happens when I try it in Safari: http://recordit.co/3RuxHFxCVA
    Please try and replicate my steps and see how it goes.

    If it still doesn't work, let me know the following:

    • What version is your Safari?
    • What version is the 1Password app on your computer?
    • Do you have any other extensions installed in Safari?
  • The key was that I had to copy the password from 1Password into the password field manually (not using autofill). The issue is that the userid is not being saved in the userid field, but in another field labelled cphBody_txtCertno. I actually deleted the USERID field in the login and it still fills in both fields. Thanks for the help.


  • Hey @amy_fried, I'm glad to hear things are working properly now. :smile: On behalf of Yaron, you're very welcome.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file