Mac App has old secret key from license and I can't log out

I am trying to get the Mac App up and running on my laptop but when I switched over to a family subscription a little while ago, the secret key changed. The Mac app won't allow me to log out and I've tried uninstalling the app and downloading it again, but it still has my old secret key in there. Please advise!

1Password Version: 7.6
Extension Version: Not Provided
OS Version: OS Catalina 10.15.6
Sync Type: Dropbox


  • ag_anaag_ana

    Team Member

    Hi @christene! Welcome to the forum!

    What happens exactly when you try to remove your existing account from the app? Do you get an error message when you say that the app won't allow you to log out?

  • Hi @ag_ana! It doesn’t even let me select my account to remove from the list which means the + and - buttons are never active.

  • I have the same issue. There is an old account on my 1Password app on my Mac laptop, can't remove it and start using my new account with active subscription which I purchased through AppStore on my iMac.

  • BenBen AWS Team

    Team Member

    Hi folks,

    If the old account is the only one in the app, you may need to reset the app. Please note this will erase all 1Password data from the Mac. To do so select Help > Troubleshooting > Reset All 1Password Data from the 1Password for Mac menu bar.

    Please let me know how it turns out.


  • @Ben Reset All worked! Thanks so much!

  • ag_anaag_ana

    Team Member

    On behalf of Ben, you are welcome @christene! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file