1Password not functioning properly. Should I reinstall software on MacOS X? If so, how

When I open 1Password on a MacBookAir with Catalina and search for an Item it always opens with the wrong item. Each time it opens with the same wrong item. I deleted that item. Now it opens each time for a search with that new incorrect Item. Shall I reinstall 1Password? If so, please provide instructions. I doubt I just Trash 1Password and may have to delete some Preference files as well. Your thoughts? My 1Password functions fine on all my Devices


1Password Version: 7.6
Extension Version: Not Provided
OS Version: 10.15.6
Sync Type: iCloud
Referrer: forum-search:reinstall Mac OS X

Comments

  • Forgot to mention that the problem involves both the Extension version in a browser as well as the Desktop Application

  • BenBen AWS Team

    Team Member

    Hi @lungrunner

    My apologies but I'm having difficulty envisioning what you're describing here. When you launch 1Password from the Dock, it is launching with a search pre-filled, and that search is for a deleted item? Is that correct?

    Ben

  • Seems to be working again. What was happening is that when I logged into 1PW and searched for something, say, AMEX, it would find the various credit cards. But if I selected Amex website to log on to check balance and clicked the open and sign on, up would pop a totally different website, say, VISA. And, no matter what I searched for in 1PW and opened the web link the same VISA website would appear. We actually deleted that VISA website in 1PW and then signed off and back on to 1PW. What would happen is that the VISA would not appear when opening a link but another website would, say, for example, MasterCard. From that point on every 1PW saved website that was opened and signed onto would be Mastercard. This would not happen with a browser Extension. But now it seems ok. Not sure why but it is working.

  • Well, I spoke too soon. Ben, when I open Desktop 1Password (for Mac with latest Catalina on a 2018 MacBook Air) with the latest 1Password Update, and search for an item to launch, find it, and hit Go, it just comes back with the same 1Password window and the same results of the previous search. In other words, it does not even launch on a browser to the desired site. But, when I launch on a browser extension, it works fine. Shall I delete 1Password Desktop? If so, is there a method to doing this? Is it a matter of dragging the Application to the trash, emptying trash, restarting and then download the Application and install? Can you provide me what to do.

  • brentybrenty

    Team Member

    That can happen if you have the browser running, but with no windows open. If you open the browser and select a Login from the 1Password toolbar button there, what happens?

  • With a browser open and then going to Desktop 1Password, Search for a Login, Open and Fill. What happens is a window opens in 1Password to do another search and the same Login (in this Search window) is always highlighted. This Login that is highlighted is the same each time Open and Fill and has nothing to do with the initial Search requested item

  • ag_anaag_ana

    Team Member

    @lungrunner:

    Would you be able to record a short video of this happening?

  • yes I could. Would it not be easier to delete and reinstall 1Password desktop application? How do I do that?

  • Working fine now with removal and reinstallation of desktop Application

  • ag_anaag_ana

    Team Member

    Thank you for the update @lungrunner! I am glad to hear this :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • 1hairleft1hairleft Junior Member
    edited October 8

    New Macbook Pro. Had the folks at Apple move everything from my old laptop to the new one. Running MacOS Catalina 10.15.6. and 1P 7.6 downloaded from Agile Bits. I used to be able to click the web site link in 1P and the page would open. That doesn't work any more. I now have to copy the URL and paste it into the text field of Safari, and hit enter to get to the page. How can I get back to being able to just click the link and go to the URL?
    FYI Was also having similar trouble with Photoshop Elements 2019. Turns out its a 32 bit program and the tech had to make some changes in my Terminal to allow it to open Photo Editor.
    Wondering if this could be a 32 bit problem with 1P and if so, how to fix it.
    Thanks for any help...

  • 1hairleft1hairleft Junior Member
    edited October 8

    n

    .

  • BenBen AWS Team

    Team Member

    @1hairleft

    Thanks for the update. 1Password has been a 64 bit app since at least v3, so I don't believe that would be a factor here. If you open Safari > Preferences > Extensions, do you see 1Password there, and if so is it checked?

    Thanks.

    Ben

  • 1hairleft1hairleft Junior Member

    Hey Ben, thanks for that info. 1P was there but not checked. I've checked it. Will try clicking the link for the URL again. I bet its gonna work now!

  • BenBen AWS Team

    Team Member

    Sounds good! :)

    Ben

  • 1hairleft1hairleft Junior Member

    Its working fine now, thanks so much! Ben, chivalry is not dead!! You are a prince among men (:

  • BenBen AWS Team

    Team Member

    And you are far too kind. :) Thanks for the update. I'm glad to hear that worked out. :+1: If we can be of further assistance, please don't hesitate to contact us.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file