App display is blank after upgrading to 0.9.5-2-33289

Hello,

I just upgraded to 0.9.5-2-33289 and the application window is blank. I uninstalled 1password, removed the local config, and re-installed the application but still have the same issue.

I am running Ubuntu 20.10 in a VM through Parallels on my 2017 iMac. Let me know if there are any specific logs that I can send to help debug the issue.


1Password Version: 0.9.5-2-33289
Extension Version: Not Provided
OS Version: Ubuntu 20.10
Sync Type: 1Password Families

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Fooligan,

    Thanks for taking the time to report this.

    Just to be clear, did it only start to do this with the 0.9.5 update?

    If you uninstall the 1Password 0.9.5 update and then run this command to install 0.9.4 (sudo apt install 1password=0.9.4-1-32510 -V), does the issue appear on that version too?

  • Hi @MikeT

    That is correct, the issue appeared after upgrading to version 0.9.5.

    I just reverted to 0.9.4 and windows are rendering normally.

  • MikeTMikeT Agile Samurai

    Team Member

    @Fooligan do you happen to use Slack?

    I'm wondering if you can test the latest beta of Slack in that VM and see if it has the same issue.

    I have a theory this may be the latest Electron build we've updated to in 0.9.5 and I think Slack also updated to that build in their latest beta build.

  • FooliganFooligan
    edited November 2020

    @MikeT

    I installed the latest beta channel of Slack using snap and it appears to work fine. Is 1Password defaulting to use hardware acceleration? I know that this type of issue crops up in Chrome when hardware acceleration is used.

  • MikeTMikeT Agile Samurai

    Team Member

    @Fooligan, yes it does use the hardware acceleration.

    The theory is that the VM's GPU driver isn't liking the changes made in the Electron update.

    Are you seeing this issue with the latest Chrome update?

  • I am using the latest version of Chrome, but with hardware acceleration off. Otherwise, I have a blank window just like the 1Password example above.

  • MikeTMikeT Agile Samurai

    Team Member

    We're looking into it. We have a confirmation that Slack's beta had the same issue in Parallels on macOS.

  • MikeTMikeT Agile Samurai

    Team Member

    @Fooligan,

    Just an update, Visual Studio Code has the same issue here.

    Try updating 1Password but before you open it, open terminal and run 1Password --disable-gpu. It should work.

    We'll look at trying to get this fixed upstream and also consider downgrading Electron in our Linux builds if possible.

  • @MikeT

    Thanks for the help! 1password --disable-gpu worked like a charm.

  • MikeTMikeT Agile Samurai

    Team Member
    edited November 2020

    No problem, thanks for bringing this up to our attention!

    Note that you'll need to append this command switch every time for now until we figure out what to do.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file