Error in fetching the PGP key from keyservers


just read David's email regarding the news on the Linux front, and wanted to install the Linux beta on my Ubuntu 20.04.1 machine.

Following the documentation at:

...and ...big issue, looks like the PGP key cannot be found at all:

# apt-key --keyring /usr/share/keyrings/1password.gpg adv --keyserver --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
Executing: /tmp/apt-key-gpghome.KZDQ2TSkdU/ --keyserver --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22
gpg: keyserver receive failed: Server indicated a failure

I have also tried with other PGP keyservers online and it looks like key ID 3FEF9748469ADBE15DA7CA80AC2D62742012EA22 cannot be found anywhere.

What am I doing wrong? It's not the first time that I use PGP keys and keyservers, considering that I have used pgp back in the 90s, right at the very beginning of it...

Many thanks,


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • Bizarre.

    I just tried the exact same command on another Linux machine I have, also an Ubuntu but an earlier 18.04.5 version, and it worked.

    Tried again on the 20.04.1 machine, and still get the error... tried changing keyserver, but no luch.

    Really weird...

  • OK, figured it out, pesky DNS issue happening with test on a machine with multiple LAN interfaces... darn DHCP client configuration, my bad!

    Looking forward to testing the new beta code!

    Bye, Luca

  • BenBen AWS Team

    Team Member

    Thanks for the update @lucaberta68. Glad to hear you were able to sort it out. :) We look forward to your feedback!


  • Is there a problem with apt key? Is it still valid?

    I also get the
    gpg: keyserver receive failed: Server indicated a failure
    with the
    sudo apt-key --keyring /usr/share/keyrings/1password.gpg adv --keyserver --recv-keys 3FEF9748469ADBE15DA7CA80AC2D62742012EA22

    I changed my dns in case that was an issue but no difference.

    I also checked directly on the Ubuntu keyserver which returns Not found for

    I running Pop_OS 20.04 which essentially is the same as Ubuntu 20.04 but the "Not found" with the keyserver is bafling.

  • Ok, just using the IP address instead worked. Guess it is another DNS issue resolving within gpg.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @flurdy,

    Thanks for updating us on that. I use Pop!_OS 20.10 and didn't see any issues with doing this. I suspect it might be your DNS server since it mentions there was a failure with the server.

    Hopefully, it shouldn't happen again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file