1Password does not fill fields on Barclays Bank website

For some reason 1Password has not completed details on the Barclays online banking site. I can't remember when it stopped working but it has been going on for some time even though it did work at some point in the past.

The site is https://bank.barclays.co.uk/olb/authlogin/loginAppContainer.do#/identification

The result is the same whether I try to use "Open and Fill" from the app or "Go" from within Safari. In both cases the website opens at the sign in page but nothing is populated. Opening 1Password from the icon in the toolbar then has an "Autofill" button. Clicking it does nothing. If I click inside the "Last name" field in the sign in form, my name does get populated. The same does not happen with the "Membership number (12 digits)" field although it is in the 1Password item. Whichever of the fields I select, the usual 1Password suggestion is not displayed. I can of course copy and paste the membership number to proceed to the next page but don't understand why it can't be accesses from within the page.


1Password Version: 7.7
Extension Version: Not Provided
OS Version: MacOS 10.14.6
Sync Type: Not Provided
Referrer: forum-search:1Password does not fill fields on Barclays Bank website

Comments

  • ag_anaag_ana
    1Password Alumni

    Hi @gengakusha!

    What browser is this happening with, and with what version of the 1Password browser extension?

  • gengakushagengakusha
    Community Member

    @ag_ana
    As I mentioned in the original post, this is happening with Safari. I didn't mention the version which is 14.0.2.

    My understanding was that the browser extension for Safari was built into 1Password rather than being a separate download which is why I did not mention the version number. It displays as 7.7, the same as the 1Password version.

  • gengakushagengakusha
    Community Member

    I also have Firefox 84.0.2 installed with 1Password extension version 4.7.5.90. I usually only use Firefox when there is functionality on the site I'm visiting which doesn't support Safari (not very often). I have tried 1Password with the Barclays site in Firefox as well and the result is effectively the same. The only difference is that with Firefox I don't need to manually select the "Last name" field for it to be populated.

  • kaitlynkaitlyn

    Team Member

    Hey @gengakusha 👋

    Happy to help! I was able to get an item filling for me after a couple tweaks. Could you give my item a try and see if you're able to fill? Here's how:

    1. Save this 1PIF (1Password Interchange Format) file to your Desktop.
    2. Double click the 1PIF file to open it up in 1Password 7.
    3. Click Import.
    4. Edit the imported Login item and click the “View Saved Form Details” button.
    5. Replace the placeholder values with your real account credentials.
    6. Save.

    Let me know if the new item fills any differently for you!

  • gengakushagengakusha
    Community Member
    edited January 2021

    Thank you @kaitlyn

    The item you sent me does fill both fields for me as well. In the case of Safari I have to click in one of the two fields on the page before they are populated, in Firefox they are populated immediately.

    If I open the page before 1Password, there is still no suggestions functionality but that is not a problem for me as my normal workflow would be to open the extension and click "go" or "open and fill" from there.

    I was curious as to why this fixes it though. I have found where you got the labels for the fields in the item but out of curiosity I tried to change those since the "Last name" field had worked for me even though I was not using "surnameMem". I had been using "surname" rather than "last name" which probably came from a previous version of the website so I changed "surnameMem" to "surname" and "membership0" to "membership" in the imported item and it still worked. I continued to shorten the label as far as just "men" and it still worked but if anything is added (other than white space) which is not in the string "membership0", it stops working. Therefore "membership " works but "membership n" doesn't. My label was initially "membership number" (which as I mentioned, worked at some time in the past) and I added the "(12 digits)" to match the text label on the website only after it stopped working. I assume it broke after a change to the website rather than a change to 1Password.

    Changing the labels in my original item also allows fixes it.

    The two things which do not work are
    1) Filling the password from within the page (the 1Password icon does not appear in the fields)
    2) Saving the login using the extension

    Neither of these things are a problem for me on this site now (although saving from the page may have fixed the field label problem) so I'm happy with this fix but longer term it would be good to see the two remaining problems addressed for this site and others like it.

    Thanks

  • I assume it broke after a change to the website rather than a change to 1Password.

    This seems like the most likely culprit, @gengakusha, although it's always possible that a filling brain update coincided with a site change and either/or could have affected things. :smile:

    Filling the password from within the page (the 1Password icon does not appear in the fields)
    Saving the login using the extension

    I'll file an issue with the development team on this one. Not showing the icon in the last name field is currently expected behavior, as we don't show the inline menu for name fields currently to avoid too many false positives, but I would expect a user to be able to save a login here and fill from the membership number field. :smile:

    ref: dev/core/core#4647

This discussion has been closed.