Mutli-row table of users, each with "email" field. How to have 1Password ignore these fields?

I have a web application, which allows me to enter rows of users (first name, last name, phone, email, etc.) None of these people are "me", but 1Password pops up with suggestions on email each time -- how can code the webpage to tell 1Password "these are not fields for you..."?

I need to use is there an additional attribute / aria value to tell 1Password to look away?


1Password Version: 7.8
Extension Version: Not Provided
OS Version: Mac Big Sur
Sync Type: Not Provided
Referrer: forum-search:tables

Comments

  • ag_anaag_ana
    1Password Alumni

    Hi @pbuck!

    I think it would be difficult to say without looking at the actual page. Are you able to share a URL with us?

  • pbuckpbuck
    Community Member

    Sure, try https://maps.avnwx.com/data/foo.html

    On clicking in any of the "email" input fields, 1Password (on Safari) will popup the "Unlock 1Password" prompt immediately under the field. You can see example image at https://maps.avnwx.com/data/1password.png

  • ag_yaronag_yaron
    1Password Alumni

    Hey @pbuck ,
    Thanks for the example.

    1Password will show up in fields it identifies as "fillable", which is determined by a mix of the page's structure, the field's name and scheme and other clues 1Password finds on the page. Since these fields are named "email", which is a very conclusive keyword for 1Password to show up, it will pop up with suggestions.

    You can either disable 1Password's inline menu suggestions from the 1Password desktop app's preferences (1Passowrd 7 -> Preferences -> Browsers -> Disabe the inline menu in Safari), or you can share the actual website's URL with us so we can teach 1Password to not show up there on our side of things. This can be done privately via email if you wish to not share this info publicly on the forum.

  • pbuckpbuck
    Community Member

    So that means a "data base browser" type of application will have issues, if it actually uses name= and column_name is "email". Too bad.

    Sounds like there's no way for me to tell 1Password otherwise (like role="cell" or role="gridcell"). (hint, hint, feature request)

    If I disable inline menu, then it's disabled everywhere (pity -- it's a nice feature).

  • ag_yaronag_yaron
    1Password Alumni

    Hey @pbuck ,
    Instead of disabling the inline menu altogether, you can just tell it to not open on its own by turning off the "Automatically show inline menu when selecting a field" in the apps preferences -> Browsers section.

    The 1Password icon will still show up on the right side of fields when you select them, so you can always open the inline menu yourself by clicking on that icon.

This discussion has been closed.