Copy not working in 0.9.13

Copy anything with the "copy" context menu but it does not paste, in 1Password or another application.

1Password Version: Linux Beta 0.9.13
Extension Version: 1.23.1
OS Version: Kubuntu 20.10
Sync Type: 1Password


  • Dayton_agDayton_ag

    Team Member

    Hey @johann_koebbe, thanks for writing in! I've tested this out myself and copying seems to be working on my machines - clicking anywhere on the desired entry field results in the specified text being copied to my clipboard. Could you tell me what steps you're taking to copy, and if 1Password notes any success/failure to copy to clipboard?

  • @Dayton_ag Thanks for checking. To copy, I have used the "Copy" option that is made available on mouse hover as well as using the disclosure triangle to reveal the "context" menu and choosing "Copy" from that. I have tried copying passwords as well as websites. 1Password displays the little bubble that says "Copied ...". I just thought to use Klipper to see if the copied text makes it to the clipboard, and it does. But, I still can't paste it. I have tried pasting into Kate and Firefox (a text field). Interestingly, if I click the item in Klipper, I can then paste it somewhere. More interestingly, if I select text in the note field of a 1Password item, then right click and choose "Copy", I can paste that somewhere. I don't know enough about clipboard functionality, but I get the impression that the entry is marked as not pastable or something. :shrug: I can try to do a screencast if that would be helpful.

  • edited February 18

    Sorry I didn't think to try this before I posted that last message. I just edited an item, then manually selected the text, right clicked and chose "Copy" and was able to paste that elsewhere. So it seems that I am not able to use 1Password's built-in copy functionality.

    EDIT: And I just now found the Edit button. :blush:

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @johann_koebbe,

    What happens if you use middle-click instead? Linux has two separate clipboards and there might be some interference with Kilpper with the general clipboard.

    Try to click normally to copy in 1Password and then paste in other apps with the middle click if you can.

  • Hi @MikeT . Middle-click paste behaves the same way. I was able to select, right-click, and copy text, then middle-click paste it, but when I choose 1P's "copy", the bubble pops up that says "Copied whatever", but middle-click pasting does nothing.

  • Dayton_agDayton_ag

    Team Member

    Hi @johann_koebbe, we've done some internal testing and we can't seem to reproduce this issue on any of our machines. As MikeT mentioned above, our best guess is that their seems to be some competition between clipboards on your device.

    Could you try uninstalling the desktop app, and re-installing? It may be a good idea to delete the sqlite file as well, and add your account back in. Here's how to do so.

  • @Dayton_ag @MikeT I think I figured it out. Setting security.clipboard.clearAfter to 0 appears to cause the issue. Per, I expected 0 to mean never clear the clipboard.

  • Dayton_agDayton_ag

    Team Member


    Ah, that's it! I tested this out and was able to reproduce it - setting security.clipboard.clearAfter to 0 does indeed clear the clipboard immediately. It seems that 1Password is now reading 0 values literally, as another user is reporting a similar issue with setting 0-values.

    I've filed this issue internally and passed it along to the Development team to take a look at - in the meantime, I suggest setting clearAfter to a non-0 number that suits your workflow. :smile: Thanks again for passing this along!

    ref: /dev/core/core/-/issues/#5170

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file