Currently locked out my 1P Android app for "infinite loading loop" at account login step

edited April 11 in Android

Everything worked fine until I updated my master key : the 1Password Android app requested an account details update... and at the "connection" step it goes into an "infinite loading loop" after complaining that "1Password cannot work without Google Play services" (which it does, because it did work since I initialized my account more than a year ago and util TODAY when I needed to update my master key)

In the end I tried :

  • fresh installation of 1P android app
  • launch, import an existing 1Password account
  • fill in all the details, click on "connection"
  • app complains about missing Google Play services
  • enters in an infinite loading loop

I used the 1Password Android app for more than a year WITHOUT ANY ISSUE, and NO Google Play services.
I have Samsung SM-G960F phone on which Google Play services are a NO-GO for security reasons.

Note that I apply all updates required by the 1Password Android app published on Google Play, even if I don't have Google Play SERVICES installed.

I'm really p***** off right now because it seems that the missing Google Play services WERE NOT REQUIRED AT ALL (it worked like a charm), and now just because people need to scan QR codes it locks out people not using Google Play services ?
I can assure you, many apps that claim "not to work without Google Play services" actually work after complaining, only the impacted features do not, say, QR code reading.

I can assure that all users not using Google Play services can ignore the missing QR code feature and would rather enter the master key by hand that install Google Play services... this dependancy is completely overkill and makes me think of moving away from 1Password just because of this...

I have no use of 1Password if I can't use it on my phone, and PLEASE do not suggest using my phone browser to access 1Password (as I read on a reddit post answered by a 1P employee), are you aware of the browser being the #1 vector of vulnerabilities and attacks ?

I understand that QR code reading is an awsome feature, but it should not BLOCK the connection process...

What could help me would be to provide a specific "version code" I could manually download from the play store, that does NOT contain the google play service update, although it is not certain that the missing Google Play services caused the infinite loading loop.

Current version code is 70704002 (for v7.7.4)

I chose 1Password for very specific reasons :

  • the way the company works
  • the application code governance (I don't install any unknown application coming from anywhere)
  • the security features
  • the supported platforms

Please tell me I didn't make the wrong choice...

1Password Version: 7.7.4
Extension Version: Not Provided
OS Version: Android 8
Sync Type: Not Provided


  • Ok too bad... I completely reset my phone and upgraded to Android 11 with stock samsung OS and Google Play services 21.09.15 from March 8, 2021.
    App no longer complains about missing Google Play services, but is still loading with an infinite loop when trying to connect to an existing account...

  • I tried with a bogus vault stored as local file : everything works as expected.

    Afterwards, if I try to add an online account (, it goes into an infinite loading loop, and if I try with a wrong Master Password, it legitimately says that it's incorrect.

  • periperi

    Team Member

    Hi @koorg. 1Password does rely on Google Play services for some functionalities, but you should theoretically still be able to use the app without these features. Can you elaborate on the loop you're encountering? Are you having trouble entering your Secret Key or Master Password?

  • Hello @peri , thanks for following up.
    No I don't have any problem entering the Secret Key or the Master Password, they are both correct and work on the 1P website or the Windows application.

    As stated in the first message, here are the steps that always lead to the same issue :

    • fresh installation of 1P android application v7.7.4
    • start the application
    • application offers to register a new account OR connect with an existing account
    • I select "connect on an existing 1password account"
    • I enter all the details correctly (scanning the account QR code from the emergency kit and entering the Master Password)
    • the "loading loop" appears and stays rotating infinitely

    I tested with an incorrect Master Password, or an incorrect Secret Key, or an incorrect e-mail address, and I have the "wrong credentials" popup in these cases.
    When all credentials are correct, the "infinite loading loop" behavior appears.

  • koorgkoorg
    edited April 12

    Probem temporarily solved by installing the full distribution of Google applications and services
    This forced a change in the security policy (presence and blocking of google services on the phone), which is not good at the moment, but hey perhaps in the future you'll identify the dependency that caused this problem...

  • periperi

    Team Member

    Hi @koorg. Thanks for the follow up. Google Play services aren't required for signing in, so it's curious that you were able to sign in after installing them. I'll report this to our developers so they can look into it.

    ref: dev/android/onepassword-android#1379

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file