Chrome extension failure to connect

I have the Mac App Store version and the Chrome extension was failing to update after I changed the master password. It would take the old one but never update to the new one.

I uninstalled the extension and re-installed it now it won't connect at all. Enter either password and it just says Connecting . NNN -- I followed the troubleshooting, restarted helper, rebooted the box. Repaired Permissions...Nothing seems to work, just have the little red bang light on the extension.

Thoughts?

Comments

  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    I have the Mac App Store version and the Chrome extension was failing to update after I changed the master password. It would take the old one but never update to the new one.

    This is expected behavior. If you change your master password, you will need to remove and reinstall the browser extension(s) as described in our support article:

    http://support.agile...ecognize-it-mac

    Just FYI, you should only change your Master Password if it is weak and needs to be made stronger or if it is also used for something else. Your 1Password Master Password isn’t like a typical Login password, and so security advice that tells people to change passwords regularly does not apply to things like your 1Password Master Password.

    In technical terms your 1Password Master Password is an encryption password instead of an authentication password; the advice used for one does not apply to the other. Once you have a strong, memorable, and unique Master Password you should not change it.

    Now, as far as resolving the problem that persists even after reinstalling the extension, it would probably be best to get a Diagnostics Report from you.

    Since you are using 1Password 3.9 (from the Mac App Store), you'll need to follow the instructions here to download the troubleshooting app and generate one:

    http://support.agile...lebits-help-you

    Then attach the entire file to an email to support AT agilebits.com.

    Please include a link to this thread in order that we might more quickly "connect the dots" when we see your Diagnostics Report in our inbox.

    Please do not post your Diagnostics Report in the forums, though.
  • I sent in a Diag report never heard anything back. Any suggestions?

    I tried reinstalling Chrome, the extension and 1Password - No luck.
  • khadkhad Social Choreographer

    Team Member
    Unfortunately, there is no message anywhere in our inbox (or spam folder even) from the address you used to sign up for these forums. That's all I had to go on, so it was all I could check. If you sent the report from another email address, could you send me a PM with that address so I can search for it? We've cleared out our inbox pretty much every day since my last post, so it would be very strange if we missed it... :S

    You could also try attaching the report to a private support ticket here:

    http://support.agilebits.com/discussion/new

    I'd love to provide further assistance, but we'll need to see the report in order to know how to provide the best assistance for your particular situation.

    You can PM me the link to your support ticket (or alternate email address from which you resend the report).

    While we're awaiting your report, could you tell me what specific versions of (1) 1Password, (2) Chrome, and (3) extension you are using? Those three version numbers could provide a clue.
  • MAS Version 3.9.5 -> Chrome 19.0.1084.46 -> Extension (tried the beta one too) 3.9.4.39499

    I put in a private support ticket as well.
  • khadkhad Social Choreographer

    Team Member
    edited May 2012
    Hi Greg,


    Thanks for sending in your Diagnostics Report! I can see from the report that there is an old 1Password background process still running on your system. I just replied to your private support ticket, but just in case anyone else is following along at home, I'll include my reply here as well. Please try this:

    In Finder, select Go > Go to Folder from the menu bar. Copy and paste the following path into the input box and then press Return:

    ~/Library/Application Support/1Password
    


    Then move the `Agent` folder you see there to the trash.

    Then copy and paste this command into Terminal (found in /Applications/Utilities) and press Return:

    launchctl unload -w ~/Library/LaunchAgents/ws.agile.1PasswordAgent.plist
    


    Once you have done both of those things, restart your Mac.

    When you Mac restarts, please open Activity Monitor (also found in /Applications/Utilities) and search for "1Password". The "1Password Helper" process should be running, but "1PaswordAgent" should not be.

    Could you confirm this for me and let me know if things are working better?
This discussion has been closed.