Read first: Previous version support information

3.9 Helper not starting on login

Hi, new here and love this software.

I have an issue with a red exclamation appearing on my Safari extension.
This happens usually when my iMac wakes from sleep or after a reboot.
I'm running Lion and the latest version of Safari and the latest 1Pasword from the App Store.

I have "Keep helper running" enabled.
And "Show Helper in menu bar" enabled.
I have also uninstalled and reinstalled the app.

The only thing that fixes this problem, is to open the main app
and enter my password, then the extension gets fixed.
I do not want to to this every time, or set the main app to start at login.
As I only mainly use the extension, and the main app I just open to store software details.

I don't know what else to try, but this happens multiple times on a regular basis.

Thanks for any help, Very much appreciated.


  • khadkhad Social Choreographer
    1Password Alumni
    edited June 2012
    Welcome to the forums, Ian0nline. Thanks for taking the time to contact us. I'm sorry that you are having this problem.

    This is actually a bug in OS X that we are tracking down in order to provide Apple with some information so that they can fix it. Sadly, 1Password is not the only application affected by this. :(

    One thing that we have seen some success with is disabling "Automatic Login" in System Preferences > Users & Groups > Login Options. If you have that enabled, try disabling it and see if that helps. Even if it is already disabled, try enabling it, restarting, then disabling it. It sounds insane — I know — but it has worked for several users.

    If that doesn't resolve the issue for you, you can "kickstart" the Helper by launching the main 1Password application after a fresh boot (as you discovered). You don't need to leave it running, but it will launch the Helper which will persist even after you quit the main 1Password application.

    We'll attempt to notify you when this is resolve, but if there is anything else we can help with until then, please let us know.
  • Ian0nlineIan0nline
    Community Member
    Thanks for the info and possible solution.
    I have followed the auto login instructions and I will see how it goes.
    I have had this problem for a while now, so please email me if anything improves.
    Thanks so much for you're time and assistance.
  • khadkhad Social Choreographer
    1Password Alumni
    It is my pleasure to help (or at least try to). Hopefully Apple can resolve this quickly.

    Let me know if you find success toggling "Automatic Login."
  • ralphdailyralphdaily Member
    Community Member
    I had the problem also and due to the this thread solved it by disabling "Automatic Login". Of course that means I don't have "Automatic Login" anymore which I did enjoy, so hope Apple fixes this. As a small matter, when I did have the problem it cured by launching the main app but unlike OP, I did not have to unlock, just launch.
  • khadkhad Social Choreographer
    1Password Alumni
    I'm glad disabling "Automatic Login" did the trick for you, ralphdaily.

    As I mentioned above, it is possible to "kickstart" the Helper by launching the main 1Password application after a fresh boot. You are correct that you do not need to unlock it. Launching the main app will load the Helper regardless of the lock/unlock state. You don't even need to leave the main app running once the Helper is loaded. The Helper will persist even after you quit the main 1Password application.

    We have never been able to reproduce the issue ourselves, but we are getting reports from some users that 10.7.5 and 10.8 resolve the issue. I'm hoping it won't be long before we can all put this behind us.
  • sandman4suresandman4sure Junior Member
    Community Member
    For me the helper also didn't load on start most of the time.
    I just put the helper in my startup items, which seems to do the trick...
  • khadkhad Social Choreographer
    1Password Alumni
    edited July 2012
    The problem with adding the Helper to your Login Items is that when you run the main application, you will have two Helpers running and conflicting with each other which will not make the problem any better and may make it worse. ;)

    It is better to simply load the main 1Password application once after a reboot as I indicated above. If you wish to automate this, add the main 1Password application to your Login Items rather than the Helper since the main app will properly "kickstart" the Helper. Then you can just quit the main application if you wish. The Helper will continue to run even after you have quit the main application.
  • pknzpknz
    Community Member
    Same issue here.

    Mac running 10.7.4

    Automatic login is disabled but the 1Password Helper does not start unless i open 1Password.

    Will just have to put up with having the 1Password Helper as a login item and quitting the second instance if I open 1Password.

    Hope it gets resolved soon.
  • terryzxterryzx Senior Member
    Community Member
    This is causing me to have to unlock the app Everytime I need to enter a password....annoying to put it mildly
  • khadkhad Social Choreographer
    1Password Alumni
    Welcome to the forums, pknz! I'm sorry you are also having this problem. As I mentioned in my post directly above yours, we do not recommend adding the Helper to your Login Items. Such a configuration is not supported, so please only proceed if you are willing to take the chance.

    terryzx, the Helper will continue to run after you launch the main application even one time, so it sounds like you may be having a different problem. Please open a support ticket so we can help:

    The good news is that we have received reports from users who were affected by this bug, and Apple has fixed it in Mountain Lion which is due out very soon now.

    I believe it should also be resolved in the 10.7.5 update for Lion which is also due soon.

    Hopefully Apple has put this behind them so we can as well. Please let me know if you are still having trouble in OS X 10.7.5 or OS X 10.8.
  • sandman4suresandman4sure Junior Member
    Community Member
    This happened today for me again, and I do use Mountain Lion now.
    I'm afraid it is not fixed...

    (I enabled automatic login again on ML)
  • khadkhad Social Choreographer
    1Password Alumni
    Sadly, it seems that this issue persists. If you haven't yet sent us a Diagnostics Report in a support ticket, we'd love to collect some more details from you:

  • Same problem here: After upgrading to ML, Helper app doesn't start up. I've got red exclamation points in Safari and Chrome. I've tried most of the items recommended in this thread, but to no avail. What's next?
  • rwakefordrwakeford Member
    Community Member
    I don't use Chrome but, with the same problem in Safari on ML, I closed Safari. Then opened 1Password and went to Help/Troubleshooting/Restart helper. Then re-opened Safari and no more red exclamation mark and all works as before.
  • khadkhad Social Choreographer
    1Password Alumni
    The issue is that there appears to be an OS X bug that might be preventing the launch of the Helper in some cases because our Team Identifier starts with a digit. :S

    As mentioned above, for now you can "kickstart" the Helper by launching the main 1Password application after a fresh boot. You don't need to leave it running, but it will launch the Helper which will persist even after you quit the main 1Password application. This is an extremely simple workaround you can use until Apple is able to resolve this or we can find a workaround.

    We have seen some folks report success by removing this file:


    However, it has not helped in all cases.
  • mattindy77mattindy77 Junior Member

    Removing the overrides.plist file for my account is what got this working for me.

    Within the /private/var/db/launchd.db directory are many other directories that begin with "" and end with a number. The number at the end of the directory is your UID in the operating system. To find your UID, you go into Applications -> Utilities -> Terminal and type the following command.


    The output will look something like this.

    uid=503(mbarton) gid=20(staff) groups=20(staff),403(,401(,12(everyone),33(_appstore),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),100(_lpoperator),204(_developer)

    My UID is 503, which means the overrides.plist file that I need to delete is located at the following path.


    After deleting the file, I logged out of my account and back into it. The file had been recreated, but the 1Password Helper wasn't configured to start at login. You must go into the 1Password application first, which will update the overrides.plist file, and then logout of your account. After you log into your account for a second time, the 1Password Helper should be running properly.

    Hope this helps!

  • khadkhad Social Choreographer
    1Password Alumni
    Welcome to the forums, Matt! Thanks for posting. I'm glad that did the trick for you. 501 is the default UID for the first user account, so that should work for most folks. However, if you have created other user accounts you will likely have a different UID (502, 503, etc.).

    There are some folks for whom this has not resolved the issue, but every success is a nice victory!

    Hopefully Apple can get this fixed soon so that it no longer requires this workaround.

  • ashleykashleyk
    Community Member
    edited August 2012
    This is such a strange problem that is hard to fathom. I had it coming and going constantly throughout the day under Lion for no apparent reason. After upgrading to ML I had it appear just once in Safari after a few days, which was eliminated by clicking on the 1Password icon in the dock and I've never seen it since. Probably just writing that will cause it to return but I am surprised to see others getting this under ML because that appears to have fixed it for me.
This discussion has been closed.