Copying and Pasting from 1Password to another App

ajmac2ajmac2 Junior Member
So I started seeing this recently. I'm running IOS 5.1.1

When I copying a password from 1Password and then paste it to another App, I noticed the stars in the App that hides the password was longer then the actual password.

So when I try to log in with the copied password, it give me an invalid username or password error.

I noticed when copying the password, it's coping the whole line.

So it's copying the word "password" also including the password right after it.

Is anyone experiencing this?



  • khadkhad Social Choreographer

    Team Member
    Hi Alvin,

    The bullets [font=courier new,courier,monospace]••••••••••[/font] that conceal the password are a fixed length. They are not representative of the actual length of any of the passwords. There are always ten of them.

    1Password should copy to the clipboard exactly what you have stored in the field. I am not able to reproduce any problem with copying passwords in the app, and so far we've not had any other reports of this.

    1. Do you have the problem with any other items or just that one?
    2. When you edit the item is the password that is stored in the field what you expect it to be?
    3. What do you see if you paste the password in a note or a plain text field where you can see what is being pasted?
    4. Try creating a new item. Do you still have the issue?

    Please let me know the answers to the above questions. I'd love to get this resolved in 1Password if there is a problem in the app.
  • edited July 2012
    I'm having the same issue. If I copy the password from Logins, it puts it into the clipboard in the form "Password[newline][password]" where [password] is my actual password - that's how it shows if I paste it into non-hidden fields

    When I want to paste the password into websites, I am having to delete all but the last 10 characters of what is in the clipboard every time (most of my passwords are 10 characters)

    1. All of the items do this

    2. Yes, it's the right password and it's correct on my other devices too

    3. When i paste it into a note it shows up as:


    i.e. the word "Password" on one line and the actual password on the next

    4. I have the issue on newly created items too.

    I have tried a hard reboot, as well as deleting and reinstalling the app to no avail

    This is relatively new behaviour, I don't think it was happening a week ago

    It's working fine on my PC and my Nexus 7
  • ajmac2ajmac2 Junior Member
    hi khad,

    By what pwandz wrote. That's exactly what I'm experiencing. In NotePad, it's pasteing the word Password and then the actual password right below it. It happens with all my passwords I'm trying to copy to another app within IOS.

  • edited July 2012
    Hi all, I assuming that your not coping from 1PasswordAnywhere, the HTML file, that's the only way I can reproduce this effect?

  • khadkhad Social Choreographer

    Team Member
    Thanks so much for the details, pwandz, and welcome to the forums. I'm sorry you're also having this problem.

    In order to track this down, we still need some more details:

    1. Could you each tell me the exact versions of 1Password and iOS that you are running?
    2. Which specific iOS device are you finding this problem on (iPhone 3GS, iPod touch 2nd gen., iPad 2, etc.)?
    3. If you have another iOS device, are able to reproduce the problem on the other device?
    4. Does the issue only apply to "Login" items or to other item types (like "Accounts") as well?
    5. Have you jailbroken the device where you are having the problem?

    What is interesting is that the iOS app was last updated almost 4 months ago. I wonder how an issue like this could only surface recently when the app has not changed since April 9.
  • edited July 2012
    Hiya, thanks for the welcome =)

    1. The software is 1Password Pro 3.6.5 (April 2), on iOS 5.1.1 (9B206)
    2. The device is an iPhone 4S
    3. Sorry, this is my only Apple device
    4. I've just now tried the other item types and I have the same issue. In fact, it's sticking the field name of ANY field in when I copy them (i.e "Number[newline][my credit card number]")
    5. No, it's stock standard

    Yeah I hesitated about reporting it because I'd assumed I'd broken it somehow. Ten bucks says it's something stupidly easy to fix haha
  • Okay, I reinstalled it one more time and it's fixed the issue.

    Hopefully it works for the other guys
  • khadkhad Social Choreographer

    Team Member
    This is truly perplexing. I can't even imagine how reinstalling the app would make a difference, but I'm glad it did.

    Alvin, presuming you are syncing your data via Dropbox and/or have it backed up, could you try removing the 1Password app and reinstalling it? Again, please do not do this without backing up your data either to another device or computer via Dropbox or by using the built-in backup feature.
  • On my girlfriend's phone, she was having more-or-less the same issue when it was first installed last year - In her case though, she'd jailbroken her phone.

    The cause in that case was an app called Action Menu was overriding the 1Password copy function with a lame one of its own.

    Maybe if y'all have jailbroken you could uninstall Action Menu?
  • khadkhad Social Choreographer

    Team Member
    Thanks for providing that info, pwandz. That was the reason I asked about jailbreaking above. There are some apps that can cause unexpected and undesirable behavior when running in the background on a jailbroken phone. :S

This discussion has been closed.