Touch id with 1Password 8

When I open 1Password 8 the program opens with the sign in screen for me to type in my password or click on the touch id image and then I can use my finger to open the program.

I wish when I open the program I didn't have to click on the touch id image in order to use the touch id. Can the touch id automatically prompt me to use my finger to I don't first need to click on the imagine before I use my finger?

This extra step is not necessary.

Thanks!


1Password Version: 8.2.2
Extension Version: 2.1.3
OS Version: 11.6
Referrer: forum-search:login

Comments

  • On the build I'm on (latest nightly) then the touch id / watch prompt appears automatically to unlock - no clicking required.

  • Now it is working when I updated to 8.4. I assumed the program would automatically install the updates. Thanks for your help. Matt

  • BenBen AWS Team

    Team Member

    Glad to hear 8.4 has improved the situation. Thanks for the update! :+1:

    Ben

  • edited November 1

    I'm on what appears to be the latest beta (80400002, on BETA channel) and I'm still having this problem, actually. Here's a link to a diagnostics report: [removed]

    Not sure what else you need to diagnose this but happy to provide it!

  • I'm running 80400019, on BETA channel and am having to enter my password every time, no Touch ID prompt.

  • fletchnifletchni Junior Member

    I am also running 8.4.0 (80400019) and and confirm this is inconsistent. So far I cannot find any logic to recreate on demand.

    Sometimes I need to click on the Touch ID Icon (which also indicates that AppleWatch integration is not working), other times I get the Touch ID on the TouchBar and my watch directly.

  • I don't even get the icon.

  • BenBen AWS Team

    Team Member

    Hi folks,

    We have made some improvements in this regard but I am still seeing some inconsistencies with biometrics and Apple Watch unlock. I've filed an issue for our team to investigate further. I'd be interested to hear: if you switch to the nightly build are things any better? You can do so in 1Password > Preferences > Advanced > Release channel, if you'd like to give it a try.

    Ben

    ref: dev/core/core#11009
    ref: dev/core/core#10725

  • I switched to nightly and still not getting the TouchID / Watch options in preferences.
    8.4 (80400033)

  • I got this to work by running the installer again. Now watch and TouchID are working as expected

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for letting us know, @urbanherder. We appreciate the info!

  • Thanks @urbanherder, reinstalling solved this issue for me also.

  • ag_anaag_ana

    Team Member

    That is great to hear @Andrew2 , thank you for letting us know :)

  • REBELinBLUEREBELinBLUE Member

    I was on the latest beta and was having this problem, just switched to NIGHTLY after reading this thread and now I get the Apple Watch prompt as soon as I open 1password

  • BenBen AWS Team

    Team Member

    That's awesome news, @REBELinBLUE, thank you. 😃

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file