SSH Client Compatibility


Team Member

With the many SSH clients out there, not every one of those supports every SSH agent configuration option.

To save you some headaches, we've been testing a lot of popular SSH & Git clients lately ourselves, and we've assembled our findings into this page:

We'd love to hear from you in the thread below which SSH clients you feel are missing from this list!

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided


  • floris_1Pfloris_1P

    Team Member
    edited March 16

    The tools we'll be covering next on the compatibility page:

    • Terraform
    • Ansible
    • TablePlus (SSH tunneling)
    • DataGrip (SSH tunneling)
    • Capistrano
    • csshX
    • rsync
    • WinSCP
  • Tertius3Tertius3
    Community Member

    Putty is missing. As far as I know, it's a quite popular ssh client for Windows.
    Putty's agent called pageant is actually using the same mechanism as the Windows OpenSSH client, only the name of the named pipe for communication is different. The only thing you seem to need to add is a named pipe with the same naming scheme as Putty.

  • joshrsmithjoshrsmith
    Community Member

    I would love to see Putty and/or MobaXTerm (can use pageant)

  • Sylv1Sylv1
    Community Member

    I would love to see PuTTY, both putty.exe and plink.exe since the last one can be used as SSH channel for git for windows through git config core.sshCommand or GIT_SSH environment variable

  • meilonmeilon
    Community Member

    I would also love pageant support, mostly for KiTTy (which itself is based on PuTTy)

  • Cu3PO42Cu3PO42
    Community Member

    While it would be nice if Pageant were supported natively, you can get this working right now by installing winssh-pageant.

  • ravesraves
    Community Member

    Be great to see support for ssh(nassh) Chrome extension which is super useful.

  • CactusBoiCactusBoi
    Community Member

    I'd love to see some support for Sequel Ace too.

    If you are on Mac and don't use TablePlus there's a 99% chance that you are using Sequel Ace.

  • scottawscottaw
    Community Member

    I cannot get either Fork or GitKraken working using the SSH_AUTH_SOCK method. Works fine with git CLI however.

  • scottawscottaw
    Community Member

    Re my above comment: Once I logged out on the Mac and logged back in again, the SSH_AUTH_SOCK export started working for the apps I tried it with. Unfortunately Fork doesn't support GPG.format = ssh so GitKraken it is (although truthfully I just use git cli for most things).

  • repolesrepoles
    Community Member

    Hi @floris_1P šŸ‘‹

    Do you have any results from your compatibility test with DataGrip (SSH tunneling)? I'm trying to create the SSH tunnel. When I click to test the connection, the 1Password authorization modal is opened, but after I authenticate, the connection fails and DataGrip shows the message "cannot connect to remote host".

  • leecolarellileecolarelli
    Community Member

    @floris_1P I had an issue getting 1Password to work with TablePlus for ages, then once I'd enabled SSH Debug Log in TablePlus and started the app via the command line, it requested access from 1Password and worked correctly. There is some issue going on there.

    See this Github thread for more details, including mine and the authors posts, which both had the same issue -

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file