1Password Safari extension disappeared

christineklingchristinekling Junior Member
Community Member

Last week I bought a new M1 MacBook Pro, and I installed 1Password and the 1Password for Safari app that got the Safari extension installed. It worked fine. Today, I went to fill in a website's password, and I noticed the extension was gone from the browser. I went to the app and clicked on the button for OPEN SAFARI PREFERENCES, and nothing happened. The link is dead. I deleted the app and reinstalled it and the same thing occurred. I rebooted the computer and did the whole thing again with reinstalling the app, and it still doesn't work. When I try to click on the button to load the extension in system preferences, it just takes me to the same place to download the app.

Any ideas as to what has happened?


1Password Version: 8.9.4
Extension Version: Not Provided
OS Version: Mac OS 12.6
Browser:_ Safari
Referrer: forum-search:Problems with Safari extension

Comments

  • GreyM1PGreyM1P

    Team Member

    Hey there @christinekling

    We have found that this happens with macOS Monterey, so there's a fix built into 1Password. Here's what to do:

    1. Open and unlock 1Password.
    2. Click the Help menu and point to Troubleshooting, then click Fix Missing Safari Extension.

    Luckily, it seems like the root cause of this problem is fixed in macOS Ventura, so hopefully the fix won't be needed for too long.

    Then, open Safari and click the Safari menu > Preferences..., and you should see 1Password on the Extensions tab as expected. Let me know how it goes. :)

    — Grey

  • christineklingchristinekling Junior Member
    Community Member

    Hi Grey,

    Worked like a charm. Thanks. I did search in the community here for "missing Safari Extension" and didn't find anything. Oh well, just glad that you guys had such a ready fix.

    -Christine

  • GreyM1PGreyM1P

    Team Member

    @christinekling – Glad to hear that solved it for you! If you ever need anything from us, please let us know. We'll be here to help. :)

  • sainsworthsainsworth Junior Member
    Community Member

    Thank you for this. I also had this problem.

    Suggestion: on the next update, have the 1Password for Safari extension note this issue in the instructions. It would have saved me an hour of frustration.

    Tx, Scott Ainsworth

  • GreyM1PGreyM1P

    Team Member
    edited October 1

    @sainsworth – I'm glad to hear those instructions helped, and I'll pass on your feedback about the troubleshooting steps to the team. Thanks for letting us know. :)

    ref: IDEA-I-1973

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file