JavaScript issue in 1Password browser

From within 1Password4 I access a companies internal web application. Unfortunately I can't provide a link for security reasons.
Anyway when open this from within 1Password4 and log in some of the links (JavaScript) in the web application don't work using the1Password4 browser.

If I log in using safari on the iPad everything including all the links work as normal. If I turn of JavaScript in safari settings the same links now don't work in safari.

Seems to indicate a JavaScript incompatibility in the 1Password4 browser.

There doesn't seem to be any browser settings in 1Password4 for the browser so nothing I can check.

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi Lindsay,

    There isn't anything we're disabling in the browser, it uses the same web view as any other mobile browser including Mobile Safari with nothing turned off. I'm not quite sure what's the issue here.

    Can you give me any ideas about those links, how are they coded, what kind of links, is it something that opens up in a new pop-up window or something like that?

  • Hi Mike,

    Thanks for the reply. Not sure what it is either. The same links and in fact the whole application works just fine on both the iPad and iPhone in mobile safari. So there's something different between the 1Password browser and mobile Safari
    Even tried opening using the url and logging in manually using my user name and password in the 1Password browser,therefore bypassing 1Password but it still didn't work.

    Can't help much as I don't understand programming, but I can pass on the information from one of the links inside the application that you select to logout. That takes you back to the logon page. Not sure if it will help though.

    javascript:__doPostBack('ctl00$ctl00$LoginStatus1$ctl00','')

    There's quite a few other areas when selected in the application that don't work either in the 1Password browser that do work just fine in Safari that I imagine use JavaScript also.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi Lindsay,

    I'm not sure what we can do without having the source code to see what it looks like in the browser. Can you tell me if you notice this behavior in other sites that's not internal, like any public accessible sites?

This discussion has been closed.