Possible trouble with old Login items in Firefox

edited March 2013 in 1Password 3 – 6 for Mac

Yesterday I was having no issue with the firefox 1password extension logging into all my sites. Last night out of nowhere I noticed when I clicked the button to log me into a series of sites, it wasn't filling in the info. I uninstalled and reinstalled it and it seem to work, but now this morning when I opened up firefox it stopped working again. I did the same thing with the installation and it worked, but now whenever I close firefox and open it, the same issue happens. It's only happening with firefox extension and it's not filling in any sites info. I had no noticeable updates on firefox so I don't know where the issue is stemming from. Any help would be great because I can not live without my 1password extensions!


  • khadkhad Social Choreographer

    Team Member

    I'm sorry that you are having some trouble, FDV8! Can you let me the URLs of a couple sites where you are having trouble? There are some known issues in the current version of Firefox, and I want to make sure we're on the same page.

    Thanks so much!

  • It's any site I visit really but a couple I use regularly are yahoo.com (mail login), macworld.com, angrybirdsnest.com and my banking sites as well. It just doesn't fill in the info, the button is there and I click it and the info is there I select it to fill and it just does nothing.

  • Catherine D.Catherine D. Junior Member
    edited March 2013

    I am also having this problem in both Firefox 19.0.2 and Safari 6.0.3 in OS X 10.8.3. I have problems at many sites, which in Firefox sometimes can be solved by disabling the extension and re-enabling it. But cmd-\ is rarely working, as far as I can tell - Barnes and Noble is a good example.

    It's completely useless for my work time card stuff (you can't get there, but the page source has a frameset in it if that helps).

    I'm actually glad to see these threads, because when this started Wednesday night, I thought I was hallucinating.

  • Hello, similar issue here. I just returned from vacation and updated extensions for Mac Firefox (3.9.10) and Safari on home Mac (OS 10.8.3). Safari seems ok but Firefox main browser (19.0.2) seems to have problems. When I start Firefox, the 1password extension icon seems to work and I can access sites. I can open a couple in a row but when I close the sites/windows, the extension stops working and will not respond. It will work again on Firefox restart and will also work if disabled and enabled in the Add-ons for another try or two.

    Everything was fine a week ago so I assume it is related to extension update or possibly FIrefox update which updates itself. Any thoughts?

  • Hello again, I tried FIrefox 19.0.2 on my MacBook Air and it worked ok with the extension upates so I figured that it might Firefox issue on my Mac. I went to Firefox- Help ->Troubleshooting Information and reset FIrefox to default settings while keeping bookmarks, etc. Seemed to fix the problem for me for now.

  • khadkhad Social Choreographer

    Team Member

    @FDV8, please try saving a new Login item and see if that helps. Let's focus on Yahoo for now.

    1. Visit the Yahoo login page in Firefox: https://login.yahoo.com/config/login
    2. Enter your credentials, but DO NOT submit the form.
    3. Click the 1Password button in your browser's toolbar, and select the "+" button in the upper right hand corner.
    4. Change the title and make any notes (if desired).
    5. Click the Save button in the upper right hand corner.

    Using the above technique I was able to save and fill a sample login at:


    I hope that helps. Please let me know.

  • khadkhad Social Choreographer

    Team Member

    @Catherine, if the site has frames then this is a known issue. Please see my post in the thread for that issue:

    There is a problem with iframes in Firefox. We have reported it to Mozilla. Either they broke it in the version of their SDK we upgraded to, or we're doing something wrong. We are waiting to hear back from Mozilla for some more details.

    If you are having a different problem, I'd love to provide you with more personalized assistance. Could you start a new thread with some more details of the specific issue including the URL where you are having trouble?

  • khadkhad Social Choreographer

    Team Member

    @doctormo, thanks for following up. I'm glad everything is working well after resetting Firefox. It is possible there is a bug in Firefox. I wonder if that will help @FDV8 or @Catherine.

  • I had the same problem with Firefox this morning. I opened my browser, navigated to Gmail and 1password button was visible on my toolbar, but clicking produced no activity. I reset Firefox - now there was no 1Password button at all (I am not sure if I managed to remove/turn off my extensions in the reset Firefox process). So I reinstalled the browser extension from 1password preferences - I can now open the extension from my Firefox browser button - but it will not autofill fields. So I am back to some functionality compared to when I turned on my PC this mornign, but I have to copy and paste from within 1password on my desktop into the browser forms :(

  • DB9DB9
    edited March 2013

    If it is any help I just saw that there are two 1password buttons available - one being the little key symbol available in the browser menu at the top, another being the 1P symbol in the bottom bar. .... Wait .... victory! Now after bashing it further (not literally). After the process described above I then when into my Firefox add-on manager, disabled 1password addon, and then re-enabled it, it now seems to work .... touchwood. I will let you know if it breaks again.

  • khadkhad Social Choreographer

    Team Member

    Thanks for following up on this, @DB9. Please do keep us posted.

    If anyone else is having trouble, could you please try installing the current beta version of the 1Password Firefox extension? Here is the direct link. Open it in Firefox and follow the onscreen instructions: https://agilebits.com/extensions/mac/firefox.html?beta=y

    If you were having trouble before switching to the beta version, did the beta version help?

  • DB9DB9
    edited April 2013

    Hey, same behaviour this morning. No autofill happening. I found that disabling and enabling the addon in firefox's preferences did it. I should note that Javascript is enabled in Firefox. I should get into more detail/disgnostics and send a bug report I guess, but that will have to wait until after family lunch :p

  • khadkhad Social Choreographer

    Team Member

    If you're still having trouble, please do send us a Diagnostics Report.

    In 1Password 3.8, just select Help > Troubleshooting > Diagnostics Report from the menu bar.

    If you are using 1Password 3.9 (from the Mac App Store), you'll need to download the 1Password Troubleshooting utility.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

This discussion has been closed.