Safari and Firefox extensions not working after hard disk replacement


Last weekend I replaced my hard disk and did a clean reinstall of my system. The Apple store genius helped out with locating and copying the 1password files to the new hard disk. The 1password mac desktop version is working fine. However, the 1password Safari and Firefox browser extensions aren't.

The Safari extension won't let me log in. It merely counts the seconds since I tried to login.
The Firefox extension does allow me to log in. But it seems to be linked to an older version of the 1password file since I see it does not update itself after I made some password changes in the 1password mac desktop version.
Both the Safari and Firefox extensions show the red dot symbol indicating a problem.

I suspect there is sync problem between the new 1password mac desktop version file and the extensions. I already uninstalled the extensions and downloaded a new versions.

Does anybody have any suggestions? Right now I often need to copy-paste logins and passwords from the 1password mac desktop version … it used to run without a hitch. Many thanks for any ideas!



  • khadkhad Social Choreographer

    Team Member

    The first thing I would suggest is removing and reinstalling the extensions.

    For Safari it's very straightforward, just remove the 1Password extension from Safari's Preferences on the Extensions pane.

    Safari handles the removal of the SQLite file automatically when you remove the extension, but you will need to do this manually for Firefox:

    1. In Firefox, select Tools > Add-ons from the menu bar.
    2. Click the Remove button to remove the 1Password extension.
    3. Quit Firefox.
    4. In Finder, select Go > Go to Folder from the menu bar.
    5. Copy and paste the following path and press Return:

      ~/Library/Application Support/Firefox/Profiles

    6. Move the OnePassword.sqlite file you see there to the desktop.

    Then reinstall the 1Password extensions in both browsers.

    Once everything is working well, you can safely move the OnePassword.sqlite file on the desktop to the trash.

    If that doesn't resolve it right away select Help > Troubleshooting > Restart Helper from the menu bar in 1Password.

    If you're still having trouble, could you please send us a Diagnostics Report?

    Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hi Khad,

    Thanks for the clear instructions.

    I removed and reinstalled the 1P extensions for both Safari and Firefox as per your instructions.

    What I see now is that the Safari extension won't let me log in. It merely counts the seconds since I tried to login as before. The Firefox extension does the same. Both the Safari and Firefox extensions show the red dot symbol indicating a problem.

    Any follow up suggestions?

    I used the troubleshooting app and have sent the diagnostic report to your support mailbox. I hope it gives added insight.


  • khadkhad Social Choreographer

    Team Member

    Thanks for emailing the Diagnostics Report, @Smacker. We'll work with you via email until everything is resolved so that we are not duplicating efforts or creating any confusion.

This discussion has been closed.