Auto Fill

How do I turn off Auto Fill with 1Browser (V4) on the iPad? Sometimes it fills every empty field on the page. Very frustrating.

Comments

  • khadkhad Social Choreographer

    Team Member

    1Password shouldn't fill anything unless you tell it to. What steps are you taking where you are seeing 1Password fill in a form? Please include the URL so we can take a look.

    Thanks!

  • Since the last update the app auto fills every single field with username, when switching pages. Try appleid.apple.com
    Auto-submit Logins off.
    annoying

  • Another example. Login to forum & click New Discussion. My Userid is entered into the discussion title field.

  • khadkhad Social Choreographer

    Team Member

    Another example. Login to forum & click New Discussion. My Userid is entered into the discussion title field.

    I can't reproduce this. What URL do you have saved in your Login item for the forum? Here is the URL for the login page:

    http://discussions.agilebits.com/entry/signin

    When I log in I am viewing the list of categories, so there is no such discussion title field on the page.

  • Khad, try appleid.apple.com

    When going through pages, change password, for instance, every single field is automatically filled with user name.

    As I wrote above, Auto-submit Logins is off.

  • khadkhad Social Choreographer

    Team Member
    edited July 2013

    Tested on appleid.apple.com. Was able to reproduce in the current stable version of 1Password. This is already fixed for the next update. Sorry for any confusion. Update forthcoming.

  • Since you have reproduced one instance ... However, just for the heck of it, login in to the forum, click on a section (e.g., iPad topics), click on New Discussion.

  • khadkhad Social Choreographer

    Team Member

    Should be resolved in the next update.

  • thanx. waiting. great app..

  • khadkhad Social Choreographer

    Team Member

    Happy to help! Thanks for your kind words, @zazan!

  • Nothing changed in the recent update.

    To reproduce: go to appleid.apple.com > phone number

    Every single field will be auto filled with username

    Not nice. Still hope u r the best...

  • khadkhad Social Choreographer

    Team Member

    We cannot reproduce this at all in 1Password 4.2.3 for iOS on an iPhone 5. Can you confirm your 1Password version number and device, @zazan? I'd love to get it fixed if there is a problem in 1Password, but we are not able to see the problem. It can be difficult to solve a problem that, by ll accounts, doesn't appear to exist. If we can figure out why you are having a different experience and reproduce the problem on our end I'm sure we can get it resolved for you too.

    Thanks!

  • I go to this page & login

    https://daw.apple.com/cgi-bin/WebObjects/DSAuthWeb.woa/wa/login?appIdKey=529eb2b096d5a3d54162171f0f29ba797e602812660013123243e58bc7bedf56&path=//index.jspa&baseURL=https://discussions.apple.com&language=US-EN

    After loging in the site takes me to https://discussions.apple.com/index.jspa at which time my Userid is placed into the Search box. Refresh the page with the same result.

    Not sure how you can test it. If I run across other examples I'll post them.

  • Click on http://forum.agilebits.com/index.php?app=core&module=global&section=login&do=process in the 1PW the Logins section. Sign in to your account. Click on the UserID at the top right of the screen which takes you to your Account page. Click on the Profile command button on the right side of the screen. My Userid is placed in all fields.

  • Create a Login with http://www.klm.com/ as the web page. Fill in Userid & Password (do not to be valid). Click on Web Name to go to KLM. All fields in Book a Flight tab are filled in with UserId. You may need to select US as destination the first time. Press the URL refresh icon, same thing happens.

  • khadkhad Social Choreographer

    Team Member

    Can you confirm your 1Password version number and device, @MikeV99?

  • System: iPhone OS (6.1.3)
    Model: iPad (3)
    Locale: en_US

    1Password Details
    Version: 4.2.3

  • khadkhad Social Choreographer

    Team Member
    edited August 2013

    I was able to easily reproduce it in 4.2.2 but couldn't in 4.2.3. I thought it was resolved, but apparently it isn't. I am still unable to reproduce this, but a couple on the team here have been able to. It's on our radar. I'm sorry for the inconvenience in the meantime.

    One workaround for now would be to navigate to the site manually and use the key icon in 1Browser to fill the Login rather than using what we call "Go & Fill" from Vault mode.

    OPI-128

  • @khad

    My devices iPhone5 and iPad3, app v.4.2.3

    Try this one as well: http://www.linkedin.com/nhome/?_mSplash=1

    Cheers

  • khadkhad Social Choreographer

    Team Member

    Thanks, @zazan! I hope you didn't miss my post above. it's on our radar and should be resolved in an update. :)

    Please let me know if there is anything else I can help with for now.

    Cheers!

  • zarafetzarafet Junior Member

    I'm using the latest version of 1Password on my iPad , with disastrous results, mainly with banking fields. My userID fills in all fields even though auto fill is off. The second field is my date of birth, which has all the fields filled in with my user ID. Then we come to the second page/stage where different fields each time require different numbers in a known sequence. Again, my userID is filled in all the fields again, a nightmare to erase from tiny boxes with dots in! Auto submit and auto fill are off.

    The web address is: https://www.pofssavecredit.co.uk/POFS-NPS/do/login?methodname=displayPresignin

    Please fix this! My account keeps getting locked down because of errors and it's Internet only banking!

  • khadkhad Social Choreographer

    Team Member

    Thank you for this URL, @zarafet. I will pass it along to the developers.

  • zarafet,

    A workaround that might help:

    In 1Password, Highlight/Select the URL to which you want to go & select Copy, open a 1Password browser window, paste the URL in the location field, then GO. You can use the password icon then to fill in the Userid/PW without the other fields being affected.

    HTHs

  • Latest iOS, latest update... same s... still

    Try again appleid.apple.com. Try changing phone numbers. Every singled field is filled with user name. This happens not on apple site only.

  • Full of bugs... More than ever before... Patch on patch...

    Stop... Take a breath, take your time and bring us normal release.

  • MeganMegan

    Team Member

    Hi @zazen,

    Thanks for checking in on us! I know this is a frustrating bug, but it looks like our developers have managed to squash it. It should show up in a future update - unfortunately I can't be more specific than that.

    We do appreciate your patience in the meantime :)

This discussion has been closed.