1Password 4.2.0 crashed on launch

LockerLocker
edited May 2013 in iOS

1PW iOS 4.2.0 (I didn't have 4.2.1 at that time).

iOS 6.1.3 (iPad)

I've tried to use 1PW 4.2.0, but the app went back to the 'finder' (actually not 'finder' but whatever it is called in iOS.)

I've tried to close the app and relaunched. It didn't solve the problem.

I've tried to reboot the iPad. It didn't solve the problem.

I checked the free space in the iPad. It was VERY low, about 25 MB. I deleted other apps to free space. Went up to 700 MB free space, but still 1PW didn't work.

I didn't find any other choice but to delete the 1PW app (along with the data) and reinstall. It downloaded the data from Dropbox. Now it is working again.

(BTW: all that is probably unrelated to having two data files on dropbox which I wrote in another post. This crash happened before I made any changes).

I have about 3400 items.

I am not sure, but I think that the size of the new data on the iPad (that came from Dropbox after the recovery) was much smaller than the data file before I deleted the App.

BTW2: what are those "Tombstones" that I saw in the log file?

Comments

  • khadkhad Social Choreographer

    Team Member

    Thanks for letting us know. Please also let us know if you have any trouble in 4.2.1.

    what are those "Tombstones" that I saw in the log file?

    "Zombie" items were "coming back to life", so we added tombstones to kill them for good. Each tombstone file is simply a placeholder to prevent inappropriate re-creation of a deleted item due to certain circumstances.

  • ... We added tombstones to kill them ...

    How sad ... :(

  • khadkhad Social Choreographer

    Team Member

    Like real zombies, the items that were resurrecting were not helpful or nice. It was the only way.... It was a tough job, but someone had to do it.

  • slothsloth Junior Member

    I have this problem, too.

    I'm running Version 3.8.21 (build 32009) on my Mac - it works perfectly

    I'm running iOS Version 3.7.2 on my iPhone 4S and my iPad 2 (Key icon with grey border), iOS 6.1.3 both

    Dropbox sync

    Both iOS apps work perfectly

    Each asks on start, "Would I like to upgrade to the New Version (no key icon)?"

    I have the new version (4.2.1) installed.

    It appears to start, populates Login list, then crashes to Home screen (this is consistent with iPhone AND iPad 4.2.1 versions

    I have tried deleting/reinstalling both iOS versions 4.2.1, restarting both devices: same result.

    What now, please?

    Thanks,

    Robin..

  • khadkhad Social Choreographer

    Team Member
    edited June 2013

    I'm sorry for the extremely delayed reply, Robin. If you are still having trouble, please email us the crash report so we can better assist you. Here are steps to obtain the report:

    Obtaining a 1Password iOS Crash Log

    Then email it to us at: [email protected] agilebits .com

    Please do not post the crash report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see it in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • I had the same issue. I've remove the following folder and files: "/Users/[username]/Library/Application Support/1Password 4", "/Users/[username]/Library/Preferences/com.agilebits.onepassword4.plist" and "/Users/[username]/Library/Safari/Extensions/1Password.safariextz". Now it work.. hope this help

This discussion has been closed.