1Password Mini Can take several seconds to open/respond to keyboard shortcuts

MacOS 10.14.4
Chrome 74.0.3729.169 (Official Build) (64-bit)
1Password 7.3
1Password Chrome Extension 4.7.4.90

Since the 7.3 update, 1Password Mini has been noticeably slow to respond to being opened (e.g. clicking the 1password icon in the Chrome toolbar or in the Mac menu bar) or when triggered via a keyboard shortcut (e.g. CMD+). In some cases, the delay has lasted up to 3 seconds. I can't recall this ever happening with prior versions of 1Password. I would have characterized prior versions of 1Password as responding "instantaneously" to keyboard shortcuts.

The delays seem to pretty consistent for a given URL/tab. So if 1Password mini takes 2 seconds to respond on a tab opened to https://discussions.agilebits.com, it will take 2 seconds to respond to successive keyboard commands on the same tab for that URL. I have noticed that this will not necessarily hold if the tab is reloaded or I open up another tab to the same URL. For instance, if i reload the tab pointed to https://discussions.agilebits.com, the 1Password mini response delay will no longer necessarily be 2 seconds - it could be faster or slower. Regardless of what the delay is after the reload, the "new" delay will hold for subsequent openings of 1Password mini for that URL/tab.

I have uninstalled and reinstalled the extension and restarted MacOS multiple times.

Sorry if this is vague ... these types of issues are hard to describe and even harder to resolve.


1Password Version: 7.3
Extension Version: 4.7.4.90
OS Version: MacOS 10.14.4
Sync Type: 1Password account

Comments

  • BenBen AWS Team

    Team Member

    Hi @carlosft

    There are a couple of reasons for this:

    1. It does take a little more processing power to decrypt and then calculate the suggested items in the new UI
    2. There is still optimization to be done, which likely won't be started until the changes to mini have stabilized

    We're still considering some changes to mini and so there are some optimizations that won't take place until after those have either been implemented or decided against.

    My apologies for any inconvenience.

    Ben

  • @Ben appreciate the quick response. While i am not super stoked that this was a known issue with the 7.3 release, a known issue is better than a mystery. Looking forward to the next release!

  • BenBen AWS Team

    Team Member

    You're very welcome. :+1:

    Ben

This discussion has been closed.