1Password extensions no longer work

For about 2 months 1Password has not recognized any extensions in my current browser, I am only ever presented with a "Install the 1Password Extension" view. I noticed the problem start at the very close to the same time in Chrome and Firefox Developer Edition. I just installed Firefox and the 1Password extension tonight and it still does not recognize that extension either. I'm currently on Chrome-74.0.3729.169, Firefox Dev-67.0b19, and Firefox-67.0.3. The 1Password extension is at 4.7.4.90 for both browsers.

I tried installing 1Password X in Firefox Dev, and that works correctly, though the shortcut doesn't always work to bring up the interface.

I have tried removing and re-adding the add-on, disabling and re-enabling the extension, restarting my browser, restarting 1Password, restarting the 1Password Extension Helper, and restarting my Macbook. My next steps will be to uninstall and re-install 1Password, but that is significantly more inconvenient to do as I use 1Password for work.


1Password Version: 7.3
Extension Version: 4.7.4.90
OS Version: 10.14.3
Sync Type: 1Password

Comments

  • ag_michaelcag_michaelc

    Team Member

    Hey @rylanh! I'm sorry to hear of the troubles you're experiencing with the 1Password extension across various browsers. At this point, uninstalling and reinstalling 1Password 7 is a great next step, and as long as you don't use any app cleaners to do so, this shouldn't be too disruptive for you, as your user data will remain untouched.

    To uninstall, please open 1Password 7, then press Control-Option-Command-Q on your keyboard to completely quit the app. Drag 1Password 7 to the Trash, then grab a fresh copy here.

    If you're still having trouble, the best thing to do will be to restart your device, reproduce the same issue, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#QQK-36494-786]

    If you’re reading this and you are not rylanh, this Support ID is for rylanh only. Please ask us for your own if you also need help.

    This will link it to our current conversation. Once we see it we should be able to better assist you. Thanks in advance!

    ref: QQK-36494-786

  • Thanks for the advise @ag_mcarlyle.

    I uninstalled & reinstalled 1Password 7 last night, and it was actually pretty painless and quick. These actions didn't have any effect, I still saw the same issue. However, I discovered that I had a second installation of 1Password 7 on my PC. This one was located in my personal Applications folder (~/Applications/1Password 7). Once I removed that application, everything is back to working again.

    So, somehow, I must have installed that second 1Password app, and it seems to have been intercepting or blocking the calls to the extension somehow. I don't recall the reason why or when I installed the second app.

    Is this a known issue, or use-case? If not, could a warning (perhaps dismissible) or log message be printed if a second installation of the same version of 1Password is found?

    Thanks for your help in getting me to discover this!
    Rylan

  • ag_anaag_ana

    Team Member

    Hi @rylanh,

    Thank you for the update! I am glad you were able to get things sorted out already :)

    The duplicate 1Password app could definitely cause what you were seeing. I can't say that this is a typical scenario, I think it's the first time I see this. I have seen a couple of instances where the 1Password app was installed in the wrong Applications folder, but not one where there were two 1Password apps installed, one in the correct place and one in the wrong one.

    The only thing I can think of is that maybe you installed one 1Password app from our website and one from the Mac App Store. Normally, they should all end up in the same Applications folder anyway, but I wonder if maybe this is what happened?

This discussion has been closed.