Removed Team Member - Can't change user on mac app

We recently parted ways with a team member. I went in to remove his account from 1password. No problem. We went to the machine he worked on and tried to sign him out and log back in as someone else. Only problem is we can't. We have deleted the app and all supporting files (we have an app sweeper that assists as well) so we have cleaned everything out and restarted machine. We logged into as admin and clicked to download app again. Only problem is once we open newly installed app....his info is already installed and we don't know his password. We can't switch account on this machine no matter what we do. We uninstalled and reinstalled and still his account is there even though he has been deleted from the admin dashboard. Sign-in to another account is greyed out.

We are stuck

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • ryanmsarver
    Community Member


    found the option through the help menu to delete all user data and that finally did it.

  • AGAlumB
    1Password Alumni

    Indeed. Sorry for the confusion there. As with most Mac apps, deleting the app itself leaves data intact (imagine if deleting Microsoft Word also deleted any Word documents on the machine!) We generally recommend against using "cleaner" apps because those often do things the user doesn't expect. Usually that means deleing data that you want to keep, but certainly they may not delete everything you want them to even if that's your goal. So we've got the option (Help > Troubleshooting > Reset All 1Password Data) to start over in 1Password for Mac if desired. Glad that helped in your case! :)

This discussion has been closed.