Chase bank autofill doesn't work in iOS

It works on my Mac, but not on any of my iOS devices


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:Chase bank autofill doesn't work in iOS

Comments

  • Has anyone figured out how to make it auto Fill?

  • Hello @Yahnski,

    Can I ask, are you using iOS 12's AutoFill (Use 1Password to fill and save on your iPhone and iPad) or are you trying to use the 1Password iOS Safari extension (Use the 1Password extension to fill in Safari and apps on your iPhone and iPad)?

    If you're finding neither works can you let us know the URL you like to use and can you confirm if this is in iOS Safari or if you're using a different browser.

  • I’m using iOS 12 autofill on my iPad and iPhone. On my MAC, I’m using the Safari extension and the autofill works just fine.

  • I’ve tried a few different URL’s, the one I’m using now is: secure07a.chase.com/web/auth/dashboard#/dashboard/overviewAccounts/overview/index

  • Hi @Yahnski,

    Armed with the URL I tested both iOS 12'a AutoFill and the 1Password iOS Safari extension.

    Using the provided URL I found with focus on the username field I was presented the AutoFill option. I selected the Login item and iOS filled both fields. I don't have a real account to test with but both fields appeared to be filled correctly. With our 1Password extension I found neither field was filled. The reason our extension failed here is as it stands the 1Password iOS Safari extension cannot interact with iframes which this page uses for the actual sign-in form. So it loads the page as per your URL but that page loads an iframe for another Chase page which contains the actual sign-in form. We can interact with iframes on the desktop, this is an iOS limitation only.

    From previous testing and troubleshooting though my dummy Chase Login item already had the following URL stored.

    https://secure07b.chase.com/web/auth/logonbox?fromOrigin=https%3A%2F%2Fwww.chase.com#/logonbox/index/index

    On the surface it looks very similar to the one you want to use but this one loads the sign-in page without needing an intermediary iframe. Testing both iOS 12's AutoFill and our extension I find both appear to fill both fields correctly.

    So AutoFill should work for both whilst our extension only works with very particular URLs, ones which don't use iframes to load the sign-in form.

    image

    I'm including an image from our support page Use 1Password to fill and save on your iPhone and iPad. Can I confirm this is how you are accessing AutoFill please. I only ask because as best I can tell AutoFill should work no matter what URL you use. If everything does point towards AutoFill can you elaborate on what is and isn't working. Do any fields fill or is it only after attempting to sign in that it fails?

  • So I did enabled the autofill for 1Password on my iPhone and iPad when I first set up 1Password on them. On my other accounts, for example Capital One, when I go to the account through 1Password the Username and Password get's filled automatically. What I have been doing is tapping the login URL in 1Password for a particular account and voila it opens up and everything is filled in - it's great! With Chase it opens up the login page, but nothing gets filled in. However, I think that thanks for your help, I may have found what does work. When I tap the password box on the Chase login page and the keyboard pops up I can tap the password key on the top of the keyboard (like in you picture) and I get a chase icon that does fill everything in when I tap it. Sometimes I don't get the Chase icon and I get "no logins found". But I think that only if I repeat hitting the password key after canceling and using tapping the chase icon to autofill. I don't know if that all make sense, but unless you have some other insights, I think you have solved my issue. Thanks

  • ag_anaag_ana

    Team Member

    @Yahnski:

    Sometimes I don't get the Chase icon and I get "no logins found".

    When this happens, are you on the same webpage that you are on when things normally work? Or are you by chance still on the Chase website, but on another page with a different URL?

  • I’m on the same webpage. I can replicate and make it happen by doing this: when I get to the logon page and tap password to get the pop up keyboard, I then tap the password key at the top of the keyboard to get the pop up with the Chase icon. Instead of tapping the icon, I cancel the action. When I tap the password key again, I get the “no logins found” in the pop up. This is of course something that I would not normally do. I think once or twice I got the “no logins” message the first time time I tapped the password key, but I don’t know how to replicate.

  • Hi @Yahnski,

    If you normally like to tap the website field in a Login item then I can explain why you've found it wasn't filling. On iOS devices we mimic open-and-fill by using 1Browser, a built-in browser that comes as part of 1Password for iOS. As the browser is inside 1Password we can control opening a page and then filling. The filling it performs though is basically the same as the 1Password iOS Safari extension and as a result it does inherent the same limitations, no filling in iframes.

    So with the first URL you kindly provided you won't see the automatic filling of the fields, not like you see with other pages. That may be where the alternative URL proves useful. Of course there is still the iOS 12 AutoFill which does seem to work.

    What I'm less sure on is the occasional no logins you're seeing. That doesn't sound right but the tricky part seems like finding a way to reproduce for filing a bug report. If you see it again could you take a screenshot for us please. If you haven't before Apple do make it pretty easy once you know how. I find the page How to take a screenshot a handy resource in these situations. If you can capture it it might be that for any reason at all you're worried about sharing it with us in quite so public a setting as our support forum. We can easily move the conversation to email so that you don't have to worry.

This discussion has been closed.