op signin panic

petermbenjaminpetermbenjamin
Community Member

I just downloaded op cli 0.6.1 for ARM (4th gen Raspberry Pi - 4GB RAM model).

I am trying to signin for the first time (e.g. "op signin my-account.1password.com [email protected] my-key"), but I get a panic:

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x120a8]

goroutine 1 [running]:
runtime/internal/atomic.goXadd64(0x12761cc, 0x1, 0x0, 0x129c001, 0x12fa030)
/usr/local/go/src/runtime/internal/atomic/atomic_arm.go:99 +0x1c
go.1password.io/op/b5/model.(Session).NextRequestID(0x1276190, 0x12fa030, 0x1)
/go/src/go.1password.io/op/b5/model/session.go:52 +0x34
go.1password.io/op/b5/api/request.Init(0x1276190, 0x1, 0x1416200, 0x37, 0x3ee2a8, 0x129c080, 0x37, 0x0, 0x0)
/go/src/go.1password.io/op/b5/api/request/request.go:213 +0x104
go.1password.io/op/b5/api/auth.SRPVerify(0x10e4120, 0x24, 0x107a600, 0x1334080, 0x20, 0x20, 0x107a540, 0x0, 0x0, 0x2)
/go/src/go.1password.io/op/b5/api/auth/auth.go:112 +0x23c
go.1password.io/op/b5/api.SigninWithCredentials(0x4cacc0, 0x107e240, 0x1076520, 0x1a, 0x4260b5, 0xd, 0x42209e, 0x7, 0x1082650, 0x9, ...)
/go/src/go.1password.io/op/b5/api/signin.go:144 +0x454
go.1password.io/op/command.(
SigninCommand).Run(0x1078748, 0x107e010, 0x3, 0x4, 0x10a63c0)
/go/src/go.1password.io/op/command/signin.go:62 +0x13c
go.1password.io/op/vendor/github.com/mitchellh/cli.(*CLI).Run(0x10ce0a0, 0x12, 0x0, 0x1)
/go/src/go.1password.io/op/vendor/github.com/mitchellh/cli/cli.go:255 +0x1a0
main.run(0x0, 0x0, 0x0)
/go/src/go.1password.io/op/main.go:47 +0x98
main.main()
/go/src/go.1password.io/op/main.go:29 +0x14


1Password Version: 0.6.1
Extension Version: Not Provided
OS Version: armv7l
Sync Type: Not Provided

Comments

  • cohixcohix
    1Password Alumni

    @petermbenjamin That's no good! It looks like something within the Go standard library is disliking the Raspberry Pi.

    I'm going to be getting one soon, and hopefully I can go in and figure out what's going on with that.

    Could you perhaps try an older version such as 0.5.7 and let me know if the issue persists there? We made some changes to the build in 0.6 and I'm curious to know if that could be causing your issue.

  • petermbenjaminpetermbenjamin
    Community Member

    Yes, I can certainly try an older version and get back to you.

  • cohixcohix
    1Password Alumni

    @petermbenjamin Thank you!

  • petermbenjaminpetermbenjamin
    Community Member

    $ ./op --version
    0.6

    $ ./op signin
    Enter the password for at :

    panic: runtime error: invalid memory address or nil pointer dereference
    [signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x120a8]

    goroutine 1 [running]:
    runtime/internal/atomic.goXadd64(0x1fd026c, 0x1, 0x0, 0x1d38301, 0x1d44120)
    /usr/local/go/src/runtime/internal/atomic/atomic_arm.go:99 +0x1c
    go.1password.io/op/b5/model.(Session).NextRequestID(0x1fd0230, 0x1d44120, 0x1)
    /go/src/go.1password.io/op/b5/model/session.go:52 +0x34
    go.1password.io/op/b5/api/request.Init(0x1fd0230, 0x1, 0x1d06b00, 0x37, 0x3ee2a8, 0x1d383c0, 0x37, 0x0, 0x0)
    /go/src/go.1password.io/op/b5/api/request/request.go:213 +0x104
    go.1password.io/op/b5/api/auth.SRPVerify(0x1c1e210, 0x24, 0x1c4e300, 0x1c1c700, 0x20, 0x20, 0x1c4e580, 0x0, 0x0, 0x2)
    /go/src/go.1password.io/op/b5/api/auth/auth.go:112 +0x23c
    go.1password.io/op/b5/api.SigninWithCredentials(0x4cacb8, 0x1c16300, 0x1c1c880, 0x1a, 0x4260b3, 0xd, 0x42209c, 0x7, 0x1c1a780, 0x9, ...)
    /go/src/go.1password.io/op/b5/api/signin.go:144 +0x454
    go.1password.io/op/command.(
    SigninCommand).Run(0x1c0e818, 0x1c0b860, 0x3, 0x4, 0x1c0c250)
    /go/src/go.1password.io/op/command/signin.go:66 +0x174
    go.1password.io/op/vendor/github.com/mitchellh/cli.(*CLI).Run(0x1cae0a0, 0x12, 0x0, 0x1)
    /go/src/go.1password.io/op/vendor/github.com/mitchellh/cli/cli.go:255 +0x1a0
    main.run(0x0, 0x0, 0x0)
    /go/src/go.1password.io/op/main.go:47 +0x98
    main.main()
    /go/src/go.1password.io/op/main.go:29 +0x14

    However, v0.5.7 seems to work.

  • cohixcohix
    1Password Alumni

    @petermbenjamin Thanks. I did some research on this and it appears there are some gotchas when using atomic operations on ARM and 386 platforms that I was not aware of. I'll make sure we address this in the next version. For now, I would suggest using 0.5.7.

  • cohixcohix
    1Password Alumni

    @petermbenjamin Version 0.6.2 has been released which should fix this!

This discussion has been closed.