Inline menu does not trigger with AWS Console Login

Issue originally posted from

With 1Password X Beta with Google Chrome (76) under MacOS, when accessing the AWS console login page I can see the email/id field, interact with it normally and see the inline 1password icon. The icon appears interactive (ie cursor changed to action when hovered).

When clicking it (while logged out of 1PX), it will prompt me to sign into 1PX (which is then possible). However there is no further menu shown. Repeated clicking (while logged into to 1PX), even after page refreshing, does not present the inline drop down menu for field completion.

I can however access the 1PX menu from the chrome toolbar, obtain the autocomplete menu and have it successfully inject details into the form as normal, so this appears limited purely to the in-field icons.

I have only noticed this recently (last few weeks) and previously the beta worked correctly. I do not see this in Firefox on the same machine (granted there is not 1PX beta for firefox).

I have confirmed this with all other extensions disabled and also under incognito mode (with only 1PX extension enabled).

1Password Version: 7.3.3-BETA
Extension Version: 1.17.0-BETA
OS Version: MacOS 10.14.6
Sync Type: Not Provided


  • kaitlynkaitlyn

    Team Member
    edited September 2019

    Hi again @novaphoenix! Thanks for starting a new thread. :)

    I'm curious if you notice the same issue in Chrome if you use the stable version of 1Password X. My guess would be no since you couldn't reproduce it in Firefox, but that will help me determine if the browser is making the difference or if it's specific to the beta. I haven't been able to reproduce it myself no matter how hard I try, so let me know and we'll go from there.

  • Hi @kaitlyn,

    I can confirm that the stable version of 1PX works correctly and shows the inline menus, even all other extensions enabled in my Chrome browser.

    The confusion continues...

  • kaitlynkaitlyn

    Team Member

    @novaphoenix – This one's stumping me! I'm wondering what would be different about the AWS Console from other sites you're using the inline menu with successfully. Is AWS the only site you've ever noticed this on, or have you come across any others while using the 1Password X beta in the last few days?

  • In my experience, this has only happened with the AWS portal. I can’t guarantee it’s limited to a single site, but I’ve not noticed the same issue elsewhere to date.

  • kaitlynkaitlyn

    Team Member

    @novaphoenix – I asked my team to try and reproduce this on their machines, just to see if they get any different results than me. In the meantime, could you gather your logs when attempting to open the 1Password X inline menu on the AWS Console? We've got a guide that explains how to obtain them here.

  • Hi @kaitlyn, sorry for the delay, but please see below for the console logs (i tried to attach, but the upload dialog is preventing it as 'file format not allowed':

    14:01:19.243 _generated_background_page.html:1 Unchecked runtime.lastError: The message port closed before a response was received.
    14:01:19.299 background.js:31 Uncaught (in promise) TypeError: Cannot read property 'indexOf' of undefined
        at ve (background.js:31)
        at ge (background.js:31)
        at background.js:31
        at Object.loginsBeforePasswords (background.js:31)
        at background.js:31
        at background.js:31
        at Array.sort (<anonymous>)
        at xR.items (background.js:31)
        at xR.itemsForTab (background.js:31)
        at Ix (background.js:31)
        at async Promise.all (index 0)
        at async Ox (background.js:31)
        at async Lx (background.js:31)
        at async Object.configure-inline-menu (background.js:31)
    ve @ background.js:31
    ge @ background.js:31
    (anonymous) @ background.js:31
    loginsBeforePasswords @ background.js:31
    (anonymous) @ background.js:31
    (anonymous) @ background.js:31
    items @ background.js:31
    itemsForTab @ background.js:31
    Ix @ background.js:31
    async function (async)
    configure-inline-menu @ background.js:31
    r @ background.js:31
  • MitchMitch

    Team Member


    I appreciate the log. It looks like one of your items for Amazon/AWS has malformed data (namely, a missing property), and it's causing the autofill menu to choke.

    Depending on how many items you have for Amazon/AWS, it might help to edit each item and re-save it. (or even make copies and delete the originals.) I will also be sure to add a validator for this property so the menu won't crash if it's missing.

    Sorry for the headache and thank you for helping us find a validation bug!


  • Hi @Mitch, thanks for the feedback on this.

    Is there any way to determine which field is at fault as I have “quite a few” being as we use 1P for our entire orgs aws multi account management so I have dozens of root account details as well as my own IAM accounts etc.


  • kaitlynkaitlyn

    Team Member

    @novaphoenix – That's a good question. Based on what the developers came up with, it seems to be the item's URL that's causing the trouble. Since we don't have any access to see your items, we aren't able to tell exactly which item the issue is associated with. I hope that narrows it down a tad.

  • Thanks for this @kaitlyn, that's been really helpful. I've been able to identify the issue and now have the inline menu working correctly.

    For reference, I had an old entry that had an empty 'website 2' and 'website 3' entry (ie fields were active, but no content). Deleting both those fields (so now 'website 2' just appears as an "incomplete" field) has corrected the issue.

    Thanks so much for all your help with this (and also @Mitch).

  • brentybrenty

    Team Member

    Great! Thanks for the update. I'm glad that did the trick. :)

This discussion has been closed.