Strange problems getting 1Password extension to work on MacBook

Community Member

I have 2 other Macs (a MacBook Pro and an iMac) that are working with the latest 1Password 7 with no issues (for months now). I recently setup a family account so that my wife could start using it. She has a "Late 2015" MacBook that didn't initially have the latest Mac OS installed. I updated to the latest MacOS and then clean installed 1Password 7 from the website download. Everything installed fine and I enabled the Extension in Safari Preferences. However, it doesn't work. The button on the browser doesn't initiate anything, and whenever I click the 1Password icon on the menubar, it just keeps saying to enable the Extension. When I click that button and it opens the Pref pane, the checkbox is enabled, but still no joy.

When I quit Safari and restart it, the button on Safari is not there anymore, and the 1Password icon on the menubar says to enable the Extension. I proceed to do so, but still the same behavior. Every time I restart Safari, the same behavior (as if the it doesn't remember that I enabled it).

I then tried a number of things:

  • I uninstalled 1Password completely using the instructions on the Agile Bits support page (delete the App, go into Terminal and remove all the folders, rebooted the Mac, etc.). I re-installed 1Password 7 using the Mac App Store, rebooted. No joy.
  • I uninstalled 1Password again using the support page steps. I re-installed 1Password 7 from a fresh website download. Same steps as above (rebooting, etc.). No joy.
  • I reinstalled the latest MacOS Mojave again. Uninstalled 1Password 7 again. Reinstalled from a fresh download. This time, it worked once, but as soon as I quit Safari and started it up again, the button on the browser is missing again and the Extension won't activate (I can check mark it to be enabled, but it doesn't make the button work and the browser doesn't remember to keep the Extension enabled after restarting.)

I don't know if this is related, but the login for the MacBook is synced to iCloud. However, access to the Safari passwords on this MacBook is via a different password (I believe the passwords are stored locally?). During my last attempt listed above, Safari said I had to Enable Extensions via the Develop menu. Doing so it asked for the password, but rather than the password to the MacBook, I had to use the local password tied to the local keychain.

Again, I have no problems with my 2 other Macs that are using 1Password 7 with Mojave brilliantly. It's this MacBook where it's not working. Any help would be appreciated. Thanks.

1Password Version: 7.3.2
Extension Version: Not Provided
OS Version: OS X 10.14.5
Sync Type: iCloud


  • icespear
    Community Member

    TL;DR - Fixed my problem by wiping out the user account on the laptop, re-creating it and signing back in to iCloud.

    Ok, after much wrangling about, I've finally solved my problem. I'll post it here in case anyone else runs into this, or if Agilebits finds it useful. I'm not exactly sure what the problem was, but suspect it has to do with an odd permissions state that I could not narrow down or get out of. This MacBook has had its steady stream of upgrades to the OS over the years. At some point in one of the upgrades, there was a conflict or confusion over the local keychain stored on the laptop and the keychain that's stored on iCloud. The MacBook account was configured to use the iCloud login to login to the laptop. But the local keychain was setup with a password that was, for a time, the same as the iCloud password. At some point, my wife changed her iCloud password. This caused the local keychain and the iCloud keychain to use different passwords. Safari was using stored passwords under the local keychain. Somehow, I think this created a weird state that 1Password was having a hard time dealing with when trying to enable the 1Password extension. It's not clear if it's a 1Password issue, an Apple issue, or some combination of both.

    I read somewhere that by changing the MacBook password will force the local keychain password to get back into sync with the MacBook password. This didn't work. So I just finally bit the bullet and signed my wife out of her iCloud account, delete her user account on the MacBook (and delete all local files/folders, etc.), re-create her account on the MacBook and sign her back in to iCloud. All of her files are on iCloud so she didn't lose any documents, etc. This seemed to do the trick and now 1Password finally works on Safari. Crazy. Hope this helps you if you're in a similar jam.

  • Ben

    Thank you for letting us know about this problem, and what worked for you to resolve it @icespear. Hopefully it helps if someone else experiences the same.


This discussion has been closed.