netlify.com Login matching

This discussion was created from comments split from: Matching sub-domains.

Comments

  • I'm reading through this and not getting the answer to my question, even though it seems like I should be.
    I have example.com as the url for a saved login. I want to use those credentials for all example.com subdomains (e.g., 1-5-7.app.example.com), but when I go to a subdomain, e.g., 1-5-7.app.example.com, my example.com credentials simply do not show up, I always have to open the 1password app and search example.com, and then they come up. Is there any way to put a wildcard in a domain so it always comes up for itself and all subdomains? Seems pretty standard to me.

  • brentybrenty

    Team Member

    @candlepop: 1Password works the way you seem to be describing, and I am not able to get it to do otherwise. So yes, it is pretty standard. :) For example, as you can imagine, I have multiple accounts for the domain agilebits.com. This forum is one of them: discussions.agilebits.com. 1Password will offer to fill any Login item matching the current domain. So my Logins with https://discussions.agilebits.com , https://www.agilebits.com , https://agilebits.com are all shown as matches. If you're seeing something different, I suspect you have something odd about the URLs you've saved, where you've saved them (they go in the "website" field -- people have been putting different information there recently, so I should mention it), or perhaps you've edited them to set them to "Never display in browser". Let me know what you find.

  • candlepopcandlepop
    edited November 2019

    @brenty I don't see any option for never display in browser. As an FYI, the url I am concerned with is netlify.com. I have it in the website field as https://netlify.com . When I go to https://deploy-preview-57829--test-abc.netlify.com/login, this login doesn't appear.

    Btw, I am using the 1PasswordX extension in Brave in case that helps. Thanks for your help

  • ag_anaag_ana

    Team Member

    @candlepop:

    I don't see any option for never display in browser.

    If you open this item in 1Password and click on the Edit button, you should see that field towards the bottom of the item window, if you scroll down a bit:

    I don't believe you can change this setting in 1Password X, it needs to be done inside the 1Password for Mac app.

  • brentybrenty

    Team Member

    @candlepop: I am not 100% sure since I can't actually get a webpage to load there (getting "Not found"), but I think you may be right. Perhaps something with that particular URL is parsing badly (the double --?). Are you having this issue at any other website, or just this one? If you go directly to https://netlify.com instead, does 1Password offer you that Login item there?

  • That was a sample url; it isn't a real one. But netlify's main login url is https://app.netlify.com/login/email and the login is not showing up in 1 Password when i'm on that page either (i need to hit ctrl period and then search for netlify in the 1PasswordX extension) and then copy and paste. I can't even autofill

  • brentybrenty

    Team Member

    @candlepop: Thanks for confirming. I think I was right about 1Password not parsing the URL currently, but it seems to not be related to the specific one you shared earlier then. We're looking into it. Thanks for bringing it up!

    ref: dev/core/filling-issues#706

  • OK cool. Can you post here when it's fixed? Thanks @brenty

  • brentybrenty

    Team Member

    I can do that. :)

  • brentybrenty

    Team Member
    edited October 16

    @candlepop: It's been a while. I hope you're well. :)

    So, we've been going through the backlog, and this came up. The whole backstory is pretty long and confusing, even for me, but I think I can summarize this reasonably well:

    The current behaviour has been correct, as I missed the important detail that Netlify had added themselves to Mozilla's Public Suffix List (for good reason; they're a hosting platform for other sites). This means they want each subdomain to be treated as a completely separate website, and as a result 1Password does not want to share Logins for x.netlify.com with y.netlify.com, etc., for example, because the owners of the two sites will be completely different people. So 1Password has actually been doing the right thing, and the appropriate solution in that case is to, if desired, add multiple URLs to the Login in 1Password if they are intended to be used with different "sites".

    However, if you looked at the PSL just now, you'll notice that netlify.com is not there, only netlify.app is! It turns out they recently had netlify.com removed from the PSL...so we're going to update that in 1Password as well. It's technically "done" already, but will take time to roll out to various platforms in updates. Per Netlify:

    netlify.com is now used for Netlify-owned properties only

    So, that's kind of good news for you, as this will be resolved for you in a future version of 1Password:

    I have it in the website field as https://netlify.com . When I go to https://deploy-preview-57829--test-abc.netlify.com/login, this login doesn't appear.

    The perhaps less-good news is that I can't say exactly when these updates will roll out, and note that it will only apply to netlify.com.

    The perhaps bad news is this other bit from Netlify:

    we added netlify.app as the new domain for Netlify customer sites.

    So...you may actually end up facing the exact same issue as before, if you have to use netlify.app now...

    As such, I've filed a feature request to investigate if there are other advanced options for Login matching that we can offer in the future. I'm purposely being vague because I don't know if or when or what may become of this, but it's something we'd like to explore, time-permitting. It's one of the many things we're keeping in mind as we work on the future of 1Password behind the scenes, but we're thinking of you. :)

    ref: dev/projects/customer-feature-requests#378

  • Thanks for the detailed update. I do appreciate it. The easiest solution (it seems to me) would be to give us a slight amount of control over the domains by allowing us to include wild cards in domains

    A new subdomain is generated every time I need to access netlify. So, there should be a way to put in a wild card like
    https://deploy-preview-%--test-abc.netlify.com/login (where the % sign represents anything) and then it'll support any domain that starts with https://deploy-preview- and ends with --test-abc.netlify.com/login (or --test-abc.netlify.app/login if that's what netlify is changing things to).

    This really doesn't seem overly complicated, but I'm obviously no expert.

  • ag_yaronag_yaron

    Team Member

    Thanks for the great suggestion @candlepop !
    We appreciate it. Hopefully we'll see some more advanced features such as this one in future versions :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file