Add users to a group without belonging to it

We recently upgraded to 1Password Business, primarily so that we could use custom groups to manage access to vaults.

If I try to use op add user_uuid group_uuid to add a user to a group, it appears that this only works if I'm already a member of the group.

I'm using an account that's in both Owners and Administrators and I can use the web UI to add people to the group whether I'm in it or not.

Curiously, I do seem to still be able to remove people from the group using op remove user group even after I remove myself.

The error message I get from the command line is as follows (I've truncated the UUIDs, but I ran it with the full values):

$ op add INN... 5i7...
[LOG] 2019/11/27 18:14:34 (ERROR)  unable to find group keyset with UUID n4p...

I get the same error if I identify the user by email address. I'm using the UUID to identify the group as I have a vault with the same name as the group in this case.

This is with version 0.8.0 on MacOS 10.14, in case that's important.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • felix_1pfelix_1p 1Password Alumni

    Thank you for the report, we will look into this!

  • felix_1pfelix_1p 1Password Alumni

    I know this is an old post but we have finally fixed this. From v1.4.0 on, users with the right privileges (e.g. admins) can add users to any group).

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file