Getting prompted for master password for autofilling password even after unlocking 1password app

Hi,

I have recently installed the app on my iPad and found that even after unlocking the app, (With master password) I get asked for the master password each time I try to login to a website. I'd click on the bottom grey bar called Password and it launches a small 1password window requesting for the master password. I've read several articles that entering the master password once via the app should stop this from happening.


1Password Version: 7.4
Extension Version: Not Provided
OS Version: ios 13.1.3
Sync Type: Not Provided
Referrer: forum-search:ios autofill master password

Comments

  • ag_anaag_ana

    Team Member

    Hi @hmukai! Welcome to the forum!

    I'd click on the bottom grey bar called Password and it launches a small 1password window requesting for the master password.

    Can you please post a screenshot of this bottom grey bar?

  • Yes here it is.

    Ideally I want to 1password to automatically fill in the email and the password automatically without even having to click somewhere else but I am not sure if that is what your product is designed to do. Dashlane did that flawlessly. Thank you.

  • ag_anaag_ana

    Team Member

    @hmukai:

    Thank you for the screenshot. That is not the main 1Password app, that's the AutoFill integration. In your first post you wrote:

    I've read several articles that entering the master password once via the app should stop this from happening.

    This is true, but please make sure you do this via the app. You need to launch the main 1Password app at least once, and enter your Master Password there, in order for FaceID to work subsequent times.

  • Hi. Yes you are correct that is not the app but as you said exactly, the browser integration for autofilling which I expect would populate the username and password automatically when I click on 'Passwords'. Also I should have been clearer. Before getting to this point, I had already unlocked the app by entering the master password. I don't know how I can visually demonstrate that to you.

  • BenBen AWS Team

    Team Member

    @hmukai

    Just to be sure we're on the same page, the way it is expected to work is:

    1. Device restarts
    2. Try to use autofill [Master Password required]
    3. Open 1Password [Master Password required]
    4. Lock timeout expires
    5. Use autofill or open 1Password [Touch ID / Face ID available]

    (you can skip step #2, it is there for demonstration purposes)

    For this to work 1Password > Settings > Security > Touch ID / Face ID must be enabled. Also note that if you use 1Password > Settings > Lock Now that will always lock such that the Master Password is required, regardless of what other settings are enabled.

    If that isn't your experience, please re-create the problem, note the time at which you were prompted for the Master Password unexpectedly, and then send us a diagnostic report. Instructions can be found here:

    Sending Diagnostics Reports (iOS)

    Change the email address on the To: line to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/109487/getting-prompted-for-master-password-for-autofilling-password-even-after-unlocking-1password-app#latest
    • Your forum username: hmukai

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!

    Ben

  • Many thanks. Can I just confirm where this setting is in? 1Password > Settings > Lock Now

    Thanks

  • BenBen AWS Team

    Team Member

    @hmukai,

    Sorry I'm not sure I understand the question. Which setting are you looking for?

    Ben

  • vplewisvplewis Junior Member

    @hmukai Lock Now is at the very top of the Security pane, so look at 1Password>Settings>Security>Lock Now. hth

  • BenBen AWS Team

    Team Member

    Just to be clear: Lock Now is not what you want, as the Master Password will always be required after pressing it.

    Ben

  • Yes with you on that. I need to know where the setting is so I can confirm that it's not enabled. Please advise.

  • Thank you vplewis. I'll check.

  • BenBen AWS Team

    Team Member

    It isn't a setting (despite being in the Settings area), it is a button. :)

    Ben

This discussion has been closed.