Autofill no longer working on Bank of America app

Community Member

I don't think autofill has worked for the username field for a long time, if ever, but the bigger problem is that now it no longer works for the password field. Here's what happens:

  1. Enter your username
  2. Tap on the password field.
  3. If autofill appears, tap it; otherwise, long-press the field and select autofill from the menu
  4. Select the appropriate login

I would expect the password field to be filled at this point. Instead, I get a toast that reads: "Your Bank of America login doesn't have a valid one-time password"

While it's true that I don't have a TOTP for that account stored in 1Password, it also doesn't support app-based TOTP.

1Password Version: 7.4.BETA-2
Extension Version: Not Provided
OS Version: Android 10, security patch from November 5, 2019
Sync Type: Not Provided


  • peri
    edited December 2019

    Hi @dcormier. Unfortunately we have noticed problems with filling into the Bank of America app. We have an open issue regarding this, and I'll pass your feedback on to our development team.

    Let us know if you notice any other issues. Thanks!

    ref: dev/android/onepassword-android#172

  • Hi @dcormier, over the weekend we put out an update to the 1Password beta which contains a fix that should get filling in the BoA app back to how it was previously. Let us know if you have any trouble with it :)

  • thejrd
    Community Member

    I also have this issue. I can work around this for now by using the 1Password keyboard, but it's somewhat inconvenient and apparently the keyboard is going to be removed in the next release anyway?! (seems like a terrible idea to get rid of the failsafe input option for cases like this!)

  • jrapps
    Community Member

    I just installed 1password, Bank of America is he first app I tried and I am getting this one time password error. If this wont work with BoA, I'm not keeping it. Will this be fixed?

  • serk_1le
    Community Member

    I am currently evaluating 1Password and this still happening. What is the status of this being fixed?

  • Hi @thejrd, @jrapps, and @serk_1le, we're currently testing the fix for this issue in our latest beta of the app (where we test fixes and new features before they make their way to the main app).

    If you'd be interested in trying it out then you'd be very welcome! You can sign up from this page:

This discussion has been closed.