Syncing problems on Mac & iOS with Windows / Web client

We have been using 1Password successfully amongst our team for a while. We use multiple vaults that we have successfully shared items in amongst the team.

Recently we have noticed problems with new vaults and syncing items to the Mac and iOS clients. Items that show up in the web UI and on the Windows UI do not show up in the Mac or iOS clients.

Also items that we create from the Mac client do not show up in the Web or Windows UI's.

Occasionally, we will see some but not all of the items in one of these new vaults appear in the Mac / iOS versions. They will often disappear again after doing something to the vault.

I'm not sure how else to explain what is happening. We have tried creating vaults from each of the different clients but get the same result. We have tried copying items from one (new) vault to another with the same result.

1Password Version: 7.4.1 MacOS, 7.3.712 on Windows
Extension Version: Not Provided
OS Version: 10.15.2
Sync Type: Not Provided
Referrer: forum-search:syncing


  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @jcono! I'm sorry for the trouble. If you have a mix of devices in the office, you'll want to make sure that the setup is done correctly on each one. 1Password can be used in standalone mode as well as with a 1Password account. Do any of the devices in question have a vault called "Primary" on them? These are standalone vaults, which are not part of your 1Password account and will not sync between devices using the servers. Make sure you're viewing All Vaults and All Items on each device that you've been having troubles with. Create a new Secure Note on each device, and give each one a unique name so it will be easily recognizable anywhere. Names like "From John's iMac" or "From Betty's PC" are good. Wait a bit and see which Secure Notes show up where. That will give you an idea of any sync issues. Let us know what you discover.

  • Lars,

    My apologies if I wasn't clear.

    We do have a mix of standalone and account vaults and I understand the difference but this is (seemingly) unrelated.

    We are able to correctly share the vaults with each other (i.e. when someone creates the vault and gives access to others it can be seen in each of the clients).

    The problem lies with the items within the vault (logins, secure notes, etc.). Only on the Windows and the web clients have we been able to see all of the items correctly and consistently. On the Mac and iOS clients the items mostly don't show up and do not seem to sync correctly with the vault.

    There problem seemed to be with one particular vault and it's entries. We have recently started using the CLI to do some automation with 1Password and this vault contains some of those entries which are both read and written by the CLI. The CLI has never had an issue with the vault and neither has the web or Windows client.

    I have recreated this vault from scratch this morning manually (there were only about 10 items) and everything seems to be ok for now.

    Here's what I can tell you (just working with the web and Mac clients this morning and with the Windows client yesterday):

    • I created a new vault on both clients and it shows up in both clients.
    • I can edit any vault on both clients and the changes are synced (name, icon, description)
    • I can manually create items in the new vaults on both clients and they are synced correctly
    • In the web client, I can currently see 17 items in the problematic vault
    • In the Mac client, there are currently only 4 items in the problematic vault
    • In the web client, I can create an item (secure note) in the problematic vault but they aren't shown in the Mac client.
    • In the Mac client, I can create an item (secure note) in the problematic vault but they aren't shown in the web client
    • When I created the secure note and save it the Mac client shows that there are only 4 items in the vault (there were already 4 before creating the note). Clicking away from that vault and back to it again shows that there are 5 items. According to the web client there are 17.
    • I can NOT copy / move the items I can see from the problematic vault to a new vault on the Mac client (it just silently fails)
    • I can NOT edit any of the items that do show in the problematic vault. The Mac client will not show the edit UI.
    • Signing out and back in on the Mac client doesn't fix the problem.
    • I can do everything correctly in the problematic vault in the web client.
    • My colleagues with the Windows client can do everything correctly with the problematic vault.
    • My colleagues can copy / move items from the problematic vault into a new vault but the problem is then recreated then in the new vault.

    Hope that helps. It's really hard to understand the cause here. For now, manually recreating the entries has worked but if the problem happens again the work involved in doing this will be prohibitive so it would be good to understand how to fix / avoid the issue.

  • LarsLars Junior Member

    Team Member

    @jcono - thanks for the comprehensive run-down. This sounds like either you might be signed in as a different user on the one Mac in question, or you've restricted specific app access to one or more of your vaults. Try signing in via the web and clicking the Vaults tab in the sidebar. Look at each vault and look at App Access. Make sure all apps (including the web app) are able to access the vaults. If it's specific people who don't have ability to see/edit items, look at the People tab of your Admin Console and click the gear (Settings) icon to the right of each vault they have access to. Make sure they're able to do the things with the data in those vaults that you want them to be able to do. Let me know what you discover. If this doesn't help you solve it, I think we should move this to the privacy of email. Let me know what you discover! :)

  • Thanks Lars but it isn't just a single Mac client and I am definitely not signed in as a different user (e.g. I can see different things when signed into the Mac client vs the web client with the same user).

    Also I don't believe we have the ability to control App Access with our subscription level (Teams).

    As we suspected the problem has appeared again as we've added more to the vault. It appears to be a problem with entries created via our automated processes that use the CLI. Once again the web and the windows client seem to be able to see it but the Mac and iOS clients can't. Interestingly the Android client also seems to be able to see them correctly.

    Would be happy to continue via email if that's more appropriate.

  • JacobJacob

    Team Member

    @jcono Thanks for the update. To get a better idea of what the issue is, let's create Diagnostics Reports from all the devices you've installed the 1Password app on:

    How to send diagnostics reports

    Be sure to create a report from all your devices so I have a full picture of how things are set up. Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread:
    • Your forum username: jcono

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :) We'll continue this conversation via email once we get those reports.

  • Jacob the number I received is:

    • [#GUP-14246-552]
  • bundtkatebundtkate

    Team Member
    edited January 10

    Thanks so much, @jcono! I've found your e-mail and someone will be in touch as soon as possible. I don't want to step on our business support team's toes too much here, particularly since I believe they will be focusing on the Mac side of things and that's not my forte, but when I saw your mention of the CLI, it piqued my interest. I do work with that client a fair bit and what you describe sounds like it could be the CLI causing the trouble. Would you mind sharing here what you did in that vault with the CLI? Was the vault itself created with the CLI? What operating system are you using the CLI tool with? Could you give me a brief overview of how you're automating what using the CLI insofar as such things might impact that vault? Basically, I'm wanting to rule out the possibility of the CLI having written some bad data mucking up things in such a way that upset your Mac app, but not others. I've seen issues of that sort before and if we've found something similar, I want to make sure our CLI development team is looped in, too. I appreciate anything and everything you're willing and able to share, including best guesses. I know it's not always viable to preserve these error states (you've got to get your work done, after all) so anything you can share would be helpful in recreating that state ourselves so we can fix it up, if that so happens to be the source of trouble. :+1:

    ref: GUP-14246-552

  • No problem @bundtkate.

    We have only just started using 1Password with our automation pipelines so our usage is not completely mature. So we're open to the possibility that we can change the way we're using it or are doing something we shouldn't.

    We have automated our application and infrastructure deployments in a way that involves providing secrets (mostly usernames and passwords) to the application code via the infrastructure. Specifically we are using terraform to create Azure key vaults from which the running application reads the values in order to do what it needs to do.

    We are integrating this with 1Password for 2 reasons:

    • some secrets are created and exist externally to the infrastructure code and we put those into a specific vault manually (using one of the clients) and during our automated build they are read from 1Password and put into the key vault in order to be made available to the application
    • other secrets are created by the infrastructure code itself, put in the key vault and then stored in 1Password for convenience (so it's easy for us to refer to them later)

    At the moment we interact with 1Password in terraform using a 3rd party terraform provider ( which uses the 1Password CLI under the hood. Currently we have it configured to use the 0.8.0 of your CLI.

    The problems we are seeing appear to show up when our automated build of our infrastructure (using this process I've just outlined) write new entries into the vault. As far as I can tell, as soon as that happened I stopped being able to see the vault correctly on both Mac and iOS.

    Everything about this process is working correctly except for the fact that on the Mac and iOs client we can't access the secrets in that vault correctly. The windows client, the web client, the Android client and the CLI (via terraform) are able to read everything from the vault as expected.

    Hope this helps.

  • cohixcohix

    Team Member

    @jcono Hello, CLI developer here. Could you provide an example of the data you’re passing into the terraform provider so I can go see what the provider is doing under the hood?

  • Hi, sure thing. It would be something like this:

    resource "random_id" "password" {
      byte_length = 20
    data "onepassword_vault" "automation" {
      name = "Automation"
    resource "onepassword_item_login" "entry" {
      name     = "somewhere login"
      vault    =
      url      = ""
      username = "username"
      password = random_id.password.b64_std
  • Hi, I am in @jcono 's team and I am experiencing the same issues and some worse ones. I have just formatted my mac and reinstalled 1Password app. I am not able to see the contents of many, many items even though I can see that the items exist. These items were not created by the automation scripts and are not in a vault created by the automation script. I could see the contents of these items before formatting my mac. Some of the items that I cannot see the contents of include items I previously created in shared vaults. When I say I cannot see the contents it means that the item is present in the list in the centre column but nothing changes on the data on the right. Other actions like [right click] -> [copy to vault] [private] also don't work.

  • cohixcohix

    Team Member

    @jcono would you be able to use the CLI to fetch one of the items in the problematic vault, remove the actual secrets from it, and then send me a message on this forum with the result? I would like to see the structure of the item to see what could be going wrong.

  • I have extracted the following using the CLI. On a good note I updated to the latest version (7.4.2 70402004) and the problems I was experiencing are no longer.

    {"uuid":"seuwb34wuzfizgqgxwhxb6qa4q","templateUuid":"001","trashed":"N","createdAt":"2019-12-19T23:02:20Z","updatedAt":"2019-12-19T23:03:15Z","changerUuid":"OHI4H7GAP5G4JBW7SGT3FDKZSY","itemVersion":2,"vaultUuid":"ctdoqys7earyqcacqc5lz4v654","details":{"fields":[{"designation":"username","name":"username","type":"T","value":"####=hidden=####"},{"designation":"password","name":"password","type":"P","value":"#########=hidden=########"}],"notesPlain":"Product Monitor uses these credentials, which is currently hard coded, and not in config.","sections":[{"name":"linked items","title":"Related Items"}]},"overview":{"URLs":[{"u":""}],"ainfo":"#####=hidden=####","ps":48,"title":"SMSBullet","url":""}}

  • cohixcohix

    Team Member

    @gbuch The only thing I can see wrong with that item is it's missing an l parameter for the URL, but that shouldn't cause 1Password for Mac to crash...

    Are the issues resolved in all of your apps? Is there anything further you would like us to investigate?

  • I believe the latest update has resolved all the issues for myself and @jcono. Thanks.

  • ag_anaag_ana

    Team Member

    Thank you for the update @gbuch! Please let us know if you see any strange behavior in the future.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file