Not autofilling new logins with generated password

Something is weird with the autofill of a generated password on a new login. I can never get it to actually fill the text field or save the login. Am I using that button wrong? Video attached. You can see it in the video but I'm repeatedly clicking on the suggested password. Is that the correct usage or should I be saving it first?

1Password Version: 7.4.2.BETA-2 (70402002)
Extension Version: 1Password X Beta 1.18.2
OS Version: MacOS 10.15.2
Sync Type:


  • I have been seeing this too, for a few weeks now. It seems to happen when 1Password is the only extension running, so I don't think it's clashing with another extension.

    I'm running Firefox 73.0b6 with 1Password X 1.18.2 and 1Password 7.4.2.BETA-2 on macOS 10.15.2 (19C57).

  • kaitlynkaitlyn

    Team Member

    Hey @bradical – that doesn't look right. What's the website URL when you're trying to create an account? I'd like to take a look at the HTML and see if I can figure out why 1Password X is behaving that way.

    @JosephDuffy – Are you noticing this on any specific websites, or are you unable to fill suggested passwords on all sites?

  • What's the website URL when you're trying to create an account?

    I'm not 100% sure but I think it was a Slack sign-up based on the screenshot.

  • kaitlynkaitlyn

    Team Member

    @bradical – Ah, that's why the font looked so familiar. I gave it a try by creating a test Slack workspace. I don't think I managed to find the exact same form as you, but the suggested password did fill properly when I tried. Could you let me know if you ever come across this in the future? The video is helpful, but it's also a huge help to get the URL or the HTML of the page if the URL can't be accessed by me. Thank you!

  • Will do.

  • kaitlynkaitlyn

    Team Member

    Thanks again :+1:

  • I see this everywhere (I can't remember the last time it worked), some examples of big sites:

  • kaitlynkaitlyn

    Team Member

    Hi @JosephDuffy! I think you may have tried to attach a video to your last comment, but I'm not able to view it. Just a heads up in case it added to your report in any way.

    For now, I'll go off of the other URLs you mentioned. I just tried filling suggested passwords on those three sites, and it filled for me. Granted, both eBay and Y Combinator didn't have the inline suggested password by default. Here's a screen recording to show you what I mean by that.

    Could you let me know the steps you're taking when 1Password X doesn't fill the suggested password for you? My guess is that you click the suggested password, and it doesn't fill, but I want to make sure there aren't certain cases where that happens that I'm not replicating correctly.

    Let me know!

  • kaitlynkaitlyn

    Team Member

    @JosephDuffy – I sent my response a bit too soon, but I wanted to add that I went ahead and filed issues for our developers in regards the 1Password X suggested password not appearing by default on eBay and Y Combinator's sign up forms.

    ref: dev/core/core#1018
    ref: dev/core/core#1019

  • Sorry @kaitlyn, that was the URL /signup on, not a video.

    The only difference I see in what we're doing is that you're using Chrome, but I am using Firefox (73.0b10).

    I've tried uploading a video showing what I'm doing (it looks to be the same as you) but I get the error "File format is not allowed." I've tried .mp4 and .mov.

  • kaitlynkaitlyn

    Team Member

    @JosephDuffy – Thanks for the heads up. I wonder if your account needs to be re-authenticated, and that's what's causing 1Password X not to fill properly for you. Could you try removing your account and adding it back? Follow these steps to do so:

    1. Right click on the 1Password icon in your Firefox browser toolbar and select Settings.
    2. Scroll to the bottom of the page, and click the Sign Out button next to your account.
    3. Click Sign in to another account.

    Go ahead and try to fill a suggested password on any website, and let me know how it goes!

  • I've just tried that @kaitlyn but it's not helped :( I also tried disabling integration with 1Password for Mac and adding the account manually (without 1Password for Mac integration) and it doesn't fill the suggested password.

  • kaitlynkaitlyn

    Team Member

    @JosephDuffy – That's super interesting. I'm wondering why I'm unable to reproduce the issue. Just to confirm, you're using 1Password X version 1.18.6.beta. Is that right?

    Can you try clicking the 1Password icon in your browser toolbar, then click the + button? After that, click on Password Generator and attempt to autofill a password via the pop-up rather than the inline suggested password. Does that fill for you?

  • @kaitlyn That's right, 1Password X 1.18.6.beta, Firefox 73.0b10.

    When I click "Autofill" the popover disappears but nothing happens on the page (the field isn't even focussed). I've tried it with the username/password field focussed, or no field focussed, but it never does anything. I can autofill existing passwords from the toolbar icon.

  • kaitlynkaitlyn

    Team Member
    edited January 29

    @JosephDuffy – I'm testing this out with Firefox Nightly, which is version 74.0a1 as well as the 1Password X 1.18.6.beta.

    When you visit while 1Password X is unlocked, are you able to see your vaults right away or are you asked to sign in?

    Go ahead and try to create a test item on (or any website, honestly). To do so, type in "test" and "test" in the username and password fields, then click Save in 1Password underneath the password field. Select any vault and click Save. Did the item save or did you receive an error?

    Let me know how these two tests go!

  • @kaitlyn I'm currently on 73.0b11.

    When I visit (while 1Password X is unlocked) I am asked for the email, secret key, and master password. If I click "< Account List" it takes me to where I can see my account. Clicking the account prompts me for my master password.

    I'm able to create new items using the method you described.

  • kaitlynkaitlyn

    Team Member

    Thanks for that info, @JosephDuffy. I'd like to take a step back and have you try uploading the video for me again, just so I can ensure I understand the issue you're experiencing as clearly as possible. Please block out any personal information since this is a public forum.

    I'd also like to check out your 1Password X log to see if there are any errors. If you don't mind, could you grab a copy for me? You can find our guide here. If you'd prefer to send them via email, you're welcome to send them to [email protected] Let me know so I can keep an eye on our inbox!

  • @kaitlyn I think I've found it! I just got back from travelling and disabled Travel Mode and it started working. Re-enabling Travel Mode causes the same behaviour seen in the OP. If you're still truggling to recreate the behaviour I will create another video (I deleted the last one).

    @bradical if you're not still following this thread, this might be of interest to you :)

  • kaitlynkaitlyn

    Team Member

    @JosephDuffy – Ah, that makes perfect sense. I'll keep that in mind in case anyone runs into the issue in the future. Thanks for sharing your solution with me! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file