1Password on Mastodon

Couldn't import data from old version

  • Is this bug reproducible?

  • Which devices did this bug appear on and is it reproducible on any devices?

​iPhone 5
  • A quick summary of the bug:

​When I tried to import Data form the old version version it fails.
  • Detailed Step-by-step instruction on how to reproduce it:
  • ​Reinstall the beta.
  • When tin for the fist time choose "Import from old version"
  • Set your main password
  • Launch the import
  • Old version opens with 'import_into_onepassword4' in Login search box and nothing is found


  • michaelloosemichaelloose
    Community Member
    I experienced the same bug on an iPhone 4S.
  • MikeTMikeT

    Team Member
    Hi guys,

    Are you using Dropbox sync 1Password 3.7.2?

    Try to disable the Dropbox sync in 1Password 3.7.2 first, kill the app in the background and then restart the import in 1Password 4, see if it'll work now.

    Please let me know how it turns out!
  • Yes I was using Dropbopx Sync in 1Password Pro 3.7.2
    I disabled Dropbox sync (just turned it off) and quit and killed the app.
    Then I removed 1Password 4 and redownload it (any way to start a sync with old version without that?) and tried to import from old version.
    Same login screen opens with 'import_into_onepassword4' in search box.
  • KosikoKosiko
    Community Member
    Same here!
    I am also using dropbox...
  • ManaburnerManaburner
    Community Member
    Same problem here. Also iPhone 4S and trying to import from 1Password Pro 3.7.2
  • Exactly this for me, too (German iPhone 4S, 1Password Pro 3.7.2). I had to set up a master password and activate the dropbox-sync manually, import didn't work and just launched the old app with 'import_into_onepassword4' in the search box.
  • For me the last beta fixed it.
    After installing the Beta 4.0b23 when I opened the 3.7.2 version a pop up told me that I have a new version of 1Password and asked me if I wand to export the data. Which I did without any problem. (I didn't reactivate dropbox synx in 3.7.2 before doing that so I can't tell if it would work with it).
  • ManaburnerManaburner
    Community Member
    Same here, but you have to deactivate Dropbox Sync in 3.7.2
  • MikeTMikeT

    Team Member
    Thanks guys, for the further confirmations. We'll have to issue another update to 1Password 3.7.x series to fix the import issue.
This discussion has been closed.