3 Input Fields (Citrix Access Gateway) - Wrong field (Token) is Auto-Populated with Password

Hi Community,

I run into a little issue, it's not a biggy, but for the life of me I do not seem to be able to figure out a solution. I hope you can point me into the right direction?

I'm using the 1Password-X plugin in a Chrome browser (all on the latest version) for filling-out a Citrix Access Gateway login page with 3 fields: Username; Token; Password.

As you can see, 1Password fills out the "Token" field instead of the "Password" field.

Is there a way to fix this behavior?

Thank you!

1Password Version: Not Provided
Extension Version: 1Password X 1.17.0
OS Version: Windows 10
Sync Type: 1Password.eu


  • ag_anaag_ana

    Team Member

    Hi @iVirusYx!

    We will be happy to test this. Would you be able to share with us this URL?

  • Unfortunately, I cannot share this with you.

    However, here is a screenshot of the HTML bit. You can see that the token field is called "passwd" and the actual password field is called "passwd1", while both are of type "Password".

  • ag_yaronag_yaron

    Team Member

    Hey @iVirusYx

    I wish we could access this page to test things, but since we can't I can only suggest you try to manually create the password field as a custom field in 1Password:
    1. Open 1Password X and locate the login for this website.
    2. Click on "Edit" so it would open in a new tab and allows you to edit the details.
    3. Under the username, password and website address, you will be able to add your own custom fields. Add a new field and call it "passwd1", change its type from "text" to "password" and input your password in it.
    4. Save and close the tab, then test and see if it autofills.

    I'm not sure if I understood correctly but you might want to put your token in the built in password field, if that is what being autofilled.
    Hopefully that will point you in the right direction :)

  • Hi @Yaron

    This seem to work as workaround, thank you.

    The token is actually an external OTP device, so the input should stay blank.
    Currently it's also populated with the password, but as I have to type anyway something into that field, it's absolutely fine with me.

    Thank you!

  • ag_yaronag_yaron

    Team Member

    Hey @iVirusYx ,
    I'm very glad to hear that worked :)

    We're here if you need further assistance with anything else.

This discussion has been closed.