1Password on Mastodon

Crash on First Sync with Dropbox

Community Member
edited November 2012 in iOS
First, thank you for allowing me access to the beta period of 1Pv4. You have obviously put a lot of effort into this software and it looks great. I definitely will not discuss or document it's existence to anyone outside of the forums and support emails with Agilebits.

Is this bug reproducible?
Yes. It occurs each time I try to sync with my existing Dropbox file.

Which devices did this bug appear on and is it reproducible on any devices?
iPhone 5

A quick summary of the bug:
1Pv4 crashes after setting up initial sync with Dropbox. It also crashes after creating a new database and then merging with my existing file on Dropbox.

Detailed Step-by-step instruction on how to reproduce it:
1. Install 1Pv4 from HockeyApp.
2. Open App > i've used 1Password before > Sync using Dropbox.
3. Dropbox app opens > Allow > 1Pv4 opens.
4. Scans Dropbox for existing file.
5. Enter master password.
6. Sync starts and makes it ~40% through data download and then crashes.
7. Opening the app after this results in an immediate crash.

I think that there may be something in my existing data causing the crash? I can set up a new database in 1Pv4 and use it fine on its own. I have been sending my crash reports when it occurs as well.

UPDATE 11.20.2012 1:41PM MST: I have tried disabling both WiFi and Cellular data to avoid syncing and get to the logs, but the app still crashes when I open it.

UPDATE 11.20.2012 3:48PM MST: I have been playing with this as much as I can and can't get the sync to finish the first time it is enabled. Once I enable Dropbox sync, it guarantees that I will have app failure on all subsequent launches.

UPDATE 11.20.2012 5:53PM MST: I tried to get my agileKeychain file to transfer using iTunes WiFi sync, but it still seems to have problems parsing a portion of my file. Any recommendations? I think I will try a file rebuild on my Mac and see if that helps.

UPDATE 11.20.2012 6:02PM MST: No dice. I rebuilt the data file from the main Mac app and allowed it to sync to Dropbox. I then re-installed 1Pv4 and tried to sync to Dropbox at initial setup and still have the sync error.

Nick Clements


  • FooliganFooligan
    Community Member
    Okay, after rebuilding the data file on the Mac app, I was able to successfully use WiFi sync to transfer the data, and then merge in iOS without any errors. I verified that all of my items were present, including attachments. I then disabled iTunes sync and enabled Dropbox sync, the error came back during the initial sync.
  • MikeTMikeT

    Team Member
    edited November 2012
    Hi Nick,

    I'm sorry to hear about the crashes.
    1. When the app were crashing, did it prompt you to submit a crash report to us?
    2. Did you notice any issues using the old 1Password 3 app on the same iPhone 5?

    Could you send us your crash reports? To do this, please connect your iOS devices to your iTunes client and let it finish its sync. Open a Finder window and select "Go to Folder" from the Go menu. Type this in the input field and then press Return:


    Go into your specific iPhone 5 folder and locate your most recent 1Password crash files, select the last 3 and zip it up. Please send it to us at [email protected] with the subject "Data file crashing 1Password 4" and a link to this thread, so that we can connect the dots.

  • FooliganFooligan
    Community Member
    Hi Mike,

    To answer your questions:
    1. I have also been sending my crash reports when the app asks on the next restart.
    2. I do not notice any errors in v3, which I have been running side by side with v4.

    I have emailed my crash reports to the support email. I hope they are helpful.

  • FooliganFooligan
    Community Member

    I also tried the following:
    1. Opened 1P3 on my Mac.
    2. Removed all web site previews.
    3. Allowed sync to Dropbox to finish.
    4. Re-downloaded 1Pv4 for my iPhone 5.
    5. Attempted to sync with Dropbox again.
    6. App crashed ~40% through sync and I can't get it to launch w/o crashing afterward.

    So, the web previews did not help.
  • FooliganFooligan
    Community Member
    I did not get a chance to test b24 since I was on the road most of the afternoon. But, in either case, b24 or b25 resolved this problem for me.
  • MikeTMikeT

    Team Member
    Hi Fooligan,

    That's great news, I'm sorry that I didn't get a chance to respond quicker but I'm glad it's working now!
This discussion has been closed.